OS/X 10.10.1 - problems using My Passport Wireless with iTunes on the Mac

I got my My Passport Wireless so that I could keep my iTunes and iPhoto (Apeture) files on it. The DNLA stuff might be fun to play with some day, but it doesn’t seem to work with much.

First important point: I have no idea why, but, yesterday, I had it working:

  • I transferred my iTunes library through USB

  • I connected to it through wi-fi (I’d prefer if it got an address through DHCP as I usually use 802.11ac, but it worked)

  • I played a film

It was a bit jerky a couple of times and went out of sync once, but it worked - these problems are probably because it’s a slow connection (1m from the laptop, but it’s only 802.11N) and because it’s formatted as FAT, not HFS+).

Still it worked.

Then, when the film ended, I tried to run another. The drive had disconnected - it was on USB power.

I’ve not managed to get it going again.

Now, when iTunes tries to access the drive, I get the error:


The iTunes Library.itl file is locked, on a locked disk or you do not have write permission for this file.


I’ve looked at the file permissions and they look fine:

-rwxrwxrwx@ 1 peterbrooks  staff   4400726 21 Nov 21:36 iTunes Library.itl

That’s exactly as it should be.

I’ve now spent an hour or two trying different things, like re-booting the drive, changing the permissions on the files etc. etc. - no joy.

Any idea what’s going on??

----- Problem II:

Also, another problem. I wanted to have a look around to see if there was some problem caused by config files or something - the browser GUI has very few options.

So I tried SSH - exactly as recommended in the manual:

ssh admin@drivename.local


I put in the password that came with the device: welc0me 

It says incorrect password

I tried the password that I’d set for the browser login - that didn’t work

I tried root and other users no joy.

So I contacted WD. They say ‘ssh is not supported’ - so they have, apparently, no idea why it isn’t working and don’t care - despite it being clearly documented in the manual…

I wrote back to WD a couple of days ago - no reply back yet.

Anybody here got an idea what this other problem might be?

Oh, and reading through the board, I see that people have re-formatted their drive.

Is it OK for me to reformat it as an OS/X HFS+ drive? That won’t cause any problems?

I am a Windows user but have iPhones and iPads, and Kindles.  I have kept my MPW formatted exFAT since I received it months ago from WD for beta testing the new product before it was released.  I considered reformatting it to NTFS, but rejected the idea, because it works perfectly as it is.  Besides, exFAT enables the MPW to be directly connected to Windows PCs AND my daughter’s Mac.

I found the following conditions help improve video streaming:  I have it connected wirelessly to my home network.  Although the MPW connects at 2.4G, I connect my iDevices to the MPW on network at (faster) 5G, and this speeds up the connection so that video performance is improved; i.e. jitter at 2.4G versus no jitter at 5G.  Higher bitrate videos are perfect using 5G (example, watch the Sample Videos on MPW at both speeds since they are quite high a bitrate.)

Suggest one live with the MPW a while before deciding to reformat it.  I have lived with mine since this summer.

1 Like

Thank you, those are very useful suggestions.

Glad it helped, and also my iTunes Media folder is on my drive as well.  Works great. The drive shuts off the wireless when on a computer.  Use it wirelessly with iDevices.  It can be accessed by computer and iThings if on the network.  I can easily load new files to it over the network, and I can contact the MPW all over the house when it on the network, too.  I keep the MPW connected to its power supply; real close to the router for max wireless between MPW and router.  Its like this 24/7 unless I want to grab it and go with it.  Enjoy it!

Mostly when such things happends I restart the computer and device and 99% it solves it.

The MPW sometimes need to be shutoff when on USB connection and restarted. On WiFi I have not had such problems.