OS 5 cannot access shares on Mobile or Web App that are not Public

I have a MyCloudMirror Gen 2 unfortunately upgraded to OS 5 that I am trying to setup multiple users on the Mobile App to only have access to the shares they have permissions for. If I set the Shares to Public, all users can see all Shares. I want to setup users that can only see the shares they have access to. I can successfully setup a user to access a share via the Mobile App and the Web App if the share is set to Public. If I switch the public setting off, even though the user has access to the share and can access the share via File Explorer, they no longer have access via the Mobile App or Web App.

Hi @BILL_CAMPBELL,

Please refer to the below link to check the article My Cloud OS5: Cannot See Shares in Web or Mobile App:
https://support-en.wd.com/app/answers/detail/a_id/29843

Thanks for the reply. I can see shares if I mark them public which means everyone can see the shares. Once I turn public off, the shares disappear for everyone. There doesn’t seem to be a setting to allow different users access to only the shares they have read/write permissions.

I’m looking for an answer to this as well. If I wanted my shared folder visible to everyone I’d put the files in the public folder!

I worked on it a bit. Here is what you do.
Create a user.
Create a shared folder, set it to private.
Under cloud access invite that user to the cloud, be sure to use an e-mail address not used before.
IE, main (admin) account is admin @admin . com
User 1 sets up an account upon getting the invite sent to User1 @ user1 . com
User 2 etc etc
I had to test using a couple different computers but you can test using different browsers most likely.
When each user logs into their very own account they will only see their share and no other in addition to everything in the public folder.

Thanks Dave,

I solved all my WD problems since the upgrade to OS5 (I consider it a downgrade), I purchased a Synology DS220+.

Synology is so far ahead of the WD offering it’s not comparable.

I suppose I should thank WD for the OS5 debacle as it forced me to really upgrade to the Synology NAS

That would be one way to go. :wink: