Orange circle of death

Ah, wait, your “3 hours” just triggered my recollection that the SMP has an energy saving setting, to shutdown after 3 hours without use!  Definitely try turning that off if you have it on.  It is under Setup > Operation > 3 Hour…

I have it enabled on one of my twoSMPs, but it never causes any issues with my Samba server.  However, it certainly might cause problems with other servers (and will slow down restart).

As for saving energy, the SMP takes <5 watts while on.  I don’t worry about turning mine off.  I can drive a couple of miles less per year or switch another incandescent to CFL/LED and save more than that.  I generally want my SMPs to start instantly and not have to reboot.

Being a server generally means running 24/7.  Having clients running without the server being on can cause problems for many protocols.  You might want to post a separate thread about best methods people have found for saving energy with SMPs.  MIght require plugging drives into the SMP itself.

3hr energy saving has been switched off.

This unit is for domestic use, so should be able to work in a domestic setup.

OP, I had the same exact problem and it drove me crazy.  It happened over WLAN and LAN, I tried different switches, different TVs, various firmware revisions, even purchased a replacement WD TV Live, same issue…  After receiving the spinning orange arrow of infinity, I’d have to reset and then no problem.  Until later…

I don’t know exactly what the problem was, but here’s how it was resolved…

I was running FreeNAS for my file storage and even tried upgrading from 7 to 8 with the same results.  I was using CIFS shares.

Several months ago, I switched my storage over to a Windows 2012 R2 server and the problem was immediately resolved.  

Some sort of incompatibility exists in the implimentation of the protocols on one of the devices, but it seems to like Windows.  

I believe you said that you had a NAS in a box which means you can’t switch it to Windows, but I would recommend sharing a bunch of files from a Windows machine and try to recreate the problem.

Since I figured this out, I love these devices and have 3 of them now.  Craft Room, Exercise room, and bedroom, they all work great, latest firmware.

I have the exact same problem.  I am using Synology NAS with NFS shares.   

RMAed a unit, same problem.  Rolled back firmware, same problem.  Disabled port forwarding on my Synolgy NAS and Netgear Router, same problem.  Turned off all junbo frames, same problem.  Tried Windows shares instead of NFS shares, smae probem.  Turned off screen saver, same problem.  Turn off 3-hours power down, smae problem.  

This is annoying!!!

I have removed the box from the living room untill a working firmware update comes out.

At the moment it’s not worth the hassle.

Same problem here multiple wdtvlive boxes connected via lan to windows media server and ds409 nas  and local USB drive all have the same issue of never ending ciruiling arrow.  I saw a reference to disable uPnP port forwarding.anyone find a fix please?