Optware on MyCloud?


I was a happy user of a My Book World Edition whose internal disk gloriously failed some weeks ago. I decided to buy a new My Cloud device, because it has interesting features like an OS based on Debian Wheezy and a dual core CPU. However, I am very disappointed by this device until now.

Apart from some actual problems with the stock firmware functions, I’m desperately trying to install the software *I* want on this box (after all, it should be *MY* cloud!!!) but:

  • if you try to use the system as a real Debian system, you’ll get into endless troubles: the apt package system is severly messed up by WD software; if you try to install packages (I even took care to set wheezy-only repositories in /etc/apt/sources.list, since the default setup seems to mix packages from wheezy and jessie… ) it’s highly probable that they won’t install (post-inst scripts fail, for instance) or that they will simply not start (“Killed”) is the only output I often get from commands…); also, apt-get prints an endless list of packages for which it doesn’t find installed files, suggesting something is really broken; I even read messages from people who tried to fix that and ended up with an almost totally bricked device with no WD software installed anymore…
  • then I decided to install Optware on it, thinking that in this way I may leave *my* installed software completely isolated from the one coming from WD (a bit sad, honestly, if you think that we may enjoy a full Debian system… anyway); but I tried both feeds cs08q1armel and cs05q1armel and even if the installation seems to go fine, in the end running “ipkg” produces just the usual laconic “Killed” output…

I searched the Internet a lot to find advanced user experiences with this device, but while a lot of stuff can be found regarding previous devices like the My Book World or the My Book Live, very few is available for the My Cloud.

I’m getting really nervous now, because the feeling that I have thrown away my money is high.

Was anyone successful at installing Optware on this device? Can anyone have an idea on how to make ipkg work?

Thanks in advance,


P.S.: I know this kind of usage is not supported by WD, but I find it really disappointing that they can’t provide a solution that does not mess up the whole system. Why don’t they just provide packages on top of the standard Debian ones, like OpenMediaVault does?? If the intent is to avoid people to brick they’re devices, in this way they obtain the exact opposite result!!

1 Like

I think it’s too late for me to give it back for a refund, I have been quite busy recently and I bought it more than one month ago, before being able to do some real work on it… But I couldn’t even imagine something like this, since, as I said, my previous experience with the MyBook World was exceptional (the only limit was the slow hardware).

I would even accept if I could get rid of the stock firmware/OS installation and install a plain Debian Wheezy on it from scratch, but it’s above my current knowledge. The main problem I can think of: is how to boot and install the system without having a console at all… Plus, I don’t have had any previous ARM experience of doing something like this, I don’t know if there are differences compared to installing an x86 system.


I have the same problem and I hate WD for it.

The problem with not being able to install software happens since the latest firmware only.

However you can easily revert to previous version and then install anything you want.

Here is how:


1 Like

Hi Nemok,

thanks for your suggestion. I’m going to try to downgrade the firmware.

Anyway, I really hope that either WD will retrace its footsteps with a new firmware upgrade that carries things back to normal or that someone else will soon publish a custom firmware that will give us back the freedom to use our device as desired! :frowning:


After downgrading the firmware, I got a bit ahead.

Now ipkg does not die with “Killed”, but gives another error:

/opt/bin/ipkg: error while loading shared libraries: libipkg.so.0: cannot open shared object file: No such file or directory
I already tried three different feeds: cs08q1armel, cs05q3armel, cs05q1armel. The result is the same.

Strange things:

  • libipkg.so.0 is where it is meant to be, that is in /opt/lib…
  • if I type “ldd /opt/bin/ipkg” the output is:  not a dynamic executable

The ldd output surprises me.

I already tried to set LD_LIBRARY_PATH=/opt/lib before starting ipkg, with no luck…

Has anyone an idea?


http://community.wd.com/t5/WD-My-Cloud/Firmware-04-00-00-607-running-btsync-or-unison-instantly/m-p/767995/highlight/false#M18314 has information regarding a similar problem.  Posting to keep the isuses linked in order to hopfully share information.  

I’d really like to be able to use software that I install without having to downgrade the firmware back to the old broken **bleep** that was such a pain in the arse before.  

For future records (in case anyone has the same question).

To make Optware work on My Cloud, especially if it’s using firmware 4.x, a new feed specific for this device would be required, since it uses a modified kernel image with non-standard 64k sized memory pages. WD provides sources and toolchain for this, but I honestly doubt that anyone will take the task to do that.

The alternative is to stick with the built-in apt package management system, but this also requires (at the moment) that packages are rebuilt from source, at least until someone comes with a “repository” of pre-built packages.

A guide to build packages from source for the My Cloud (firmware 3.x or 4.x) is here:


Unfortunately WD did a big mistake, IMHO, by making installing third-party software so hard to achieve on this device. However it’s fair to say that I was contacted by the WD technical support who proposed me a refund if I’m not satisfied with this product, although we’re talking about a feature which is explicitely declared as not supported by the  manufacturer. I appreciated this and I think I’ll trust again WD in the future, although, as I said, they’re missing the opportunity to please advanced (but still consumer) users with this device, which is in a segment where WD has almost no competitor (other solutions from other manufacturers are usually different in terms of price, size and complexity of the solution).

I am having the same issue, do you have a solution?


Lasy **bleep**…

Software repo for v4 firmware

Alternative firmware

My Google drive folder (Many useful stuff)

GPL source code - is what you need for rebuild debian packages (for v4 fw)