oops something not matching up. did you type the code correctly?

I have WD Myclould home, I purchased that in 2019, and it was new. I never worked on it until last week. I have connected to my home network as instructed, and I run into the setup page, but when it comes to the activation code page, I can’t pass this page even though I am writing the correct activation code. It keeps giving me an error that the activation code is not correct.

I have contacted support, but unfortunately they informed me that there are a lot of errors in the system file and the hard drive is not working properly. I can access the hard drive through the network, and I can add files and do whatever I need to do in the public folder, which confirms to me that this is not a hard drive issue. It is software. Anyone who faced the same issue as mine

Usually a different browser will eventually allow Google tracking to allow the authentication of the user as shown in this thread.

As to the whether hard disk error, you can read the smartdata.log yourself in the debug_logs.tar file that you downloaded and make your own decision.