Onto my 3rd RMA (WD10EARS)

I’ve never had a problem with WD BEFORE i got a WD10EARS. then the pain and misery began, each time suffering from the same fault.

first one i got, hooked it up, did a 4k Format worked for a good 3 months, then the I/O errors began to rear their ugly head.

exactly the same with the second drive and now the third.

Test Option: QUICK TEST
Model Number: WDC WD10EARS-00Z5B1
Firmware Number: 80.00A80
Capacity: 1000.20 GB
Test Result: FAIL
Test Error Code: 06-Quick Test on drive 2 did not complete! Status code = 07 (Failed read test element), Failure Checkpoint = 102 (Unknown Test) SMART self-test did not complete on drive 2!
Test Time: 23:32:10, July 21, 2012

Ran this 3 times to check wether or not it was lying to me but no, exactly the same thing.

The thing is my WD10EACS hasn’t had a problem, and its getting on abit.

I’ve tried it in different sata ports / different OS’s / Different PC and still the same.

Is there someone who can get me a NEW drive, as it seems the refurbished ones were fit for the scrap heap

Are you using any type of external enclosure or RAID case? Or you have it connected directly to the PC motherboard?

nope, nothing special going on here - thought it might have been a  faulty molex > sata converter issue, so connected it directly to its own sata rail and still the same thing.

Did a full zero on the drive, re-initialized, quick formatted and began copying some distros onto it.

It got through ~900mb of data then froze completely, i then cancelled that to find it had then disappeared from explorer.