Only want RAID functionality not Cloud

I purchased the Mirror for its RAID functionality for photos. For various reasons I will not use/don’t want the Cloud functionality.

Is there a way to connect the Mirror to my computer via USB for faster access (both directions)?

When setting up I thought I saw mention of it but can’t find anything now.



No, the MCM cannot be connected via USB, only ethernet. The USB ports are only there to add additional drives to the MCM, which will appear as shares on the MCM.

But it is possible to directly connect the MCM to a computer with its ethernet cable, although of course you’ll lose access to the ethernet port for networking etc (you’ll have to use wifi).

Depending on your router you may get an increase in speed by doing so, but if it’s a good fast router then the increase may be small. The drive should appear under network as usual, and Quickview/Smartware should both see it as normal (if you use those).

And as you’ve no doubt already found, if you don’t want the cloud functionality then just turn it off via the dashboard.

DarrenHill, thanks.

But if I connect directly to the computer why would the router be involved? A little confused on that sentence. Just using WIFI is okay.

It may be that I was given the wrong information on the product to buy. I am just trying to have essentially 2 backups of my photos. My Internet access is quota restricted so the Cloud is useless to me.


I meant that if your router is a good modern fast one, then the speed difference between being PC <> Router <> MCM may not be so different than just PC <> MCM if all the connections are by ethernet (and using decent cabling). If your PC is linked to the router by wifi, if the network/router is busy or if it is older (non gigabit speed)  then the direct connection will definitely be faster.

But the fastest way will just be to do the direct connection as mentioned, although of course then it will also only be available to the computer that it is connected to rather than all PCs on your network.

Also to be clear, the cloud functionality only comes into play if you’re connecting to the MCM from outside your network via the WD apps (or if you set port forwarding up on your router and connect via that manually). If it’s just sat on your home network and the PC is also on your home network (by wifi or ethernet) then the cloud aspect doesn’t come into play at all. That’s how I use my MCM at home, the cloud stuff is all turned off as I don’t need it (by doing so it saves processor overhead on the MCM too, and is also one less potential security hole in my network set-up).

Thanks for a quick response! And a great solution.

I have now connected the RAID drive directly to my computer, but cannot access/find the drive.


Do I need to re-install the Cloud software?

To be clear - you are connecting the whole MyCloud Mirror to the computer, not having removed a single drive from it and connected that somehow?

Anyway, presuming that you’ve connected the MCM itself via the ethernet cable to the ethernet port on your computer, and that the computer is running Windows then the MCM should appear under the network tab in Windows Explorer, just the same as it does when you have it normally on the network. No WD software is needed for that.

If it doesn’t appear, go into Control Panel and check the properties of the LAN connection (of your ethernet port). You need the Client for Microsoft Networks and TCPIP installed - if you’re not sure take a screenshot of the properties page and post it up so we can look at it.

As it’s directly connected it should turn up straight away, but one last thing you could try is to access the drive via \WDMYCLOUDMIRROR in Windows explorer, or whatever you’ve called it when you set it up.

  1. Yes

  2. That’s what I thought should happen but didn’t.

  3. The IP address has changed and it will not locate it. I can “force it” into the WD software, can access settings, etc. but not the files.

  4. Both MN and TCPIP are installed for the controller. If through Control Panel I select Network and on the left side expand Network - nothing shows BUT if I just select Network (not expand) on the left side the MCM shows on the right side as a Storage device. I can even make a shortcut on my Desktop. But I cannot connect to it to view files and no software program “sees” it. It attempts to connect via Firefox to a new IP address but never does - “Problem loading page”.

I really bought the wrong device :frowning: . Thanks for you help.

Also check that the MCM and the Windows machine are set to use the same workgroup.

But it does sound odd that you can see it in the network overview, but not in the list. Having said that my MCM on my network sometimes disappears from that drop-down list in the same way, but by using the \ way it will find it again. I think it’s timing out in the network seeking as my Pi does the same thing sometimes too, but my wife’s Windows laptop always shows up (it’s in the same homegroup as my laptop). But as the MCM is directly connected in your case then there should not be any kind of time-out I would have expected.

Why are you forcing a round peg into a square hole?

Just go get an external RAID array such as the My Book Duo or whatever.

Gee, thanks Tony for the help!

I purchased the Mirror based on the recommendations of a techie whom I thought understood what I needed to do. Obviously mistaken.