Only one of two WD My Passport discs shows at a time

Hello …

I have two WD My Passorts USB discs. If I plug in either, all is well. If I plug in both, then only the first to be plugged in is visible.

I have tried a Scan For New Devices, to no avail.

I have tried it on two PCs.

This seems as though it is an oversight by the WD Driver programmer. Can it be corrected? Or is there something I can do?

I need to be able to transfer files between the two discs. Surely not an impossible demand eh?

[Intel Core2Quad, 16Gbyte RAM, Win Vista Ultimate x64]

Many thanks

kaspencer

Hello,

If you access Disk Management can you see both drives online?

It’s a Windows thing see post 11 here   http://community.wdc.com/t5/My-Passport-for-PC/Copy-files-from-one-drive-to-another/m-p/277504/highlight/false#M7587 

Joe

Thanks for the replies …

Awo…

Only the first drive to be connected shows up in disc manager. But in Device Manager -> USB devices there are two WES drivers listed. But neither WES driver tells me anything about the drive etc.

Joe…

I have read the post mentioned, and will get back to you when I have tried the procedure posted by Ayhan. I can’t do it immediately as I am not on the specific PC. But I have noted that DiskPart is available on my Windows 2003 server so it should be on the Vista PC too.

I’ll be in touch!

Ken.

Joe …

I understand exactly what is being said in that post, and I have used DiskPart as described. But unfortunately, only one WD My Passort disc seems to be useable or even connectable at a time. The second My Passport disc to be connected does not show up at all in DiskPart.

If I plug in a second USB disc of a different model/manufacturer all is well.

So, any further help with this? It could well be a matter for WD.

Ken.

Well, it seems that the WD My Passport USB discs have decided to behave themselves.

After great problems getting them to connect reliably even singly, suddenly all is well.

The discs can now be connected simultaneously and both can be seen.

So, problem resolved. Not that I did anything to resolve it.

Thanks for all the comments.

Regards (have an excellent Christmas!)

Ken