Only able to access my MyCloud in one room of the house

Does anybody have a clue what could cause an access problem with the MyCloud in different rooms in the house.

We currently have an Apple router in the living room and an EE one in the study coming in from the main telecoms feed.  I can log on to the drive with both the main log in and the remote log in in the living room, but as soon as I go into any other room in the house I am unable to access either by the main or the remote log in.  To us this doesnt make sense and have been going nuts trying to solve it.

We have unplugged it from the router in the living room and plugged directly into the EE router in the study but that hasn’t made a difference either.

As of yet I have not tried to access away from home with the remote access.

My guess is that your two routers are creating two completely different networks.  You don’t want that – you want the same network no matter which router you’re connecting to.

Additionally, logon to the computer when connected to each one of these routers and look at the output of “ipconfig” command at the command window.

What are the Subnet mask and Default gateway values displayed for the two cases?


The gateway is  The second router is and the NAS is…subnet mask is so all on same network and all devices are shown as connected on the main router.  But still no access to the WD in any room other than the living room.

Tried another solution by turning off the Apple Time Capsule and re-booting the EE router…suddenly I had access from another room…turned the Time Capsule back on and I kept access for about another 45 minutes and then it suddely wouldn’t connect to it again.