Ongoing .TS files FF / RW issues?

Searched and found many references to FF / RW problems with .TS videos; anyone know if this issue has been addressed in the latest model WD TV Live?

I have to say here that I find it a bit strange that my .TS files exhibit no such problems when played on either VCL Media Player or my Humax HDR-Fox T2?

But not with my ‘old’ WD TV Live… with the latest software/firmware I should add?

Any ideas… thanks in advance…

I do not own a SMP myself, but based in the reviews I have read it can playback .TS files without issues.

WD-40 wrote:

Searched and found many references to FF / RW problems with .TS videos; anyone know if this issue has been addressed in the latest model WD TV Live?


Exactly what issues are you having doing FF / REW?   I don’t have any issues doing that…

FF & RW of TS files is almost ‘useless’ - at best clunky, as I explained I don’t have such problems with VLC (for example) or on my HUMAX HDR Fox T2 ?

I expected at least to have TS file control as good as on other players, the WDTV Live is supposed to be able to FF or RW properly, smoothly - surely?

I’m still not understanding…

What do you mean “Clunky?”

When I FF or RW, it does exactly that…  goes forward or backward at the set rate until you press PLAY, then it resumes…

Only with TS files, by ‘clunky’ I mean unreliable, unpredictable, sometimes selecting FF will stop play completely and take the viewer back to the file list - ready to start again from the beginning?

Other owners here have complained of similar issues when playing TS videos, my Son in Oz has the latest TV Live and reports similar issues with TS… :frowning:

The WDTV Live is a microprocessor controlled media streaming box using a hardware digital video chip. Computers use a software media player and codecs to programme the CPU and GPU to mimic the functions of a hardware digital video chip.

Too many people complaining about TS files not playing correctly are using pirated torrent downloads. What happens when you virgin rip a bluray disk and play the TS files?  

Firstly, I appreciate your help.

My downloads are not pirated; I am not in a position to be able rip blu-ray discs.

Like I say, my Humax HDR-Fox T2 FF’s and RW’s the same .TS files smoothly with no problems… I kind’ve expected the WD TV Live to be able to?

Sigma will not release the technical details for their chip set range. What is known is that the inbuilt Sigma hardware digital video chip complies fully with the professional international digital video standards. A hardware digital video chip is faster than a GPU. A hardware digital video chip is not programmable; therefore, if the digital video is outside the professional international digital video standards unfortunately the video will not play.

If your downloads are legitimate, they should comply with the professional international digital video standards. Sometimes the download process generates bad bits. I would post a compliant with your video provider and ask if there is a checksum verifier to confirm your download.

The WDTV Live range of streamer boxes are reliable. On the volume produced there are very few complaints. If your download checksum verifies and you still experience problems, lodge a complaint directly with WD. There is a possibility you may have a faulty Sigma chip.

I am also having FF issues on .ts files. The issues I am having are this:

  • I hit FF (I tried with all speeds and the same issue arises)

  • when I get passed the comercial, I hit play

  • most times it will resume back to the point when I originally hit FF (before the comercial)

  • sometimes it will kick me out to the file list

  • the issue seems to be worse as it gets further into my recordings

I am on a wired lan to my server and there is at most 3 devices on the lan. My server has a gig NIC card connected to a gig switch. These files are not downloaded but recorded from OTA broadcast. Since they are ATSC standard, the theoretical bit rate could be up to 19mbps but my recordings are closer to 16mbps. When I re-encapsulate the same stream into an mkv container (not transcoding), the issues go away. This last point proves it’s not a bitrate or network issue. If I don’t hi FF, the file plays fine the entire way through.

Gincognito:  That issue may be related to how broadcast TV is put into the TS container.

If the resolution /aspect ratio/ audio coding / etc. changes mid-stream (which is quite possible in broadcast recordings) the WDTV probably can’t handle that…

You might wanna try remuxing the file with ProjectX which should result in a compliant stream.