One computer cannot access MyBook Live

Recently got a 1TB MyBook Live to store photos on to make sharing things like family photos easier, I can access and transfer files from my computer with ease and I can access it from an iPad, but one computer on the network, running win7, can’t access it.

I can access the dashboard site for it from the computer in question and it shows up under “Network” in Explorer, however when I try accessing it all I get is an error message saying it’s not accessible. Sometimes a logon prompt will appear, but when I try entering any of the user credentials it gives me a “account is disabled” error.

I’ve been searching around the web and trying pretty much every solution, but so far nothing has worked. I does show up in the WD mapping software, but it won’t let me map it.


What about the firewall settings on that computer, are you able to disable those settings just for troubleshooting purposes?

Hi, check if UPNP is enabled for the PC and also that the Client for Microsoft Networks is active in the local area connection properties window. 

1 Like

I had a similar problem awhile back . WD Link could see the MBL but could not map it. I also could not map the MBL (or any other drive via Explorer in WinXP SP3). Tried all the usual solutions including those suggested above and also checked Permissions, Protocols, Pinged the devices OK, Services, updated NIC Drivers, etc . Nothing worked.

The problem was finally resolved by the simple process of uninstalling the NIC in Device Manager and then ‘Scan for hardware changes’. That re-installed the NIC (an Intel PRO/1000CT in an old ASUS P4C800-E MB) and that resolved the problem.  If nothing else has worked you might give that a try. Good luck.

Thank you all for your help.

I can disable the firewall and I have tried disabling both firewall and anti-virus, although I had already tried that before I posted here.

UPNP and the Client for Microsoft networks are both enabled.

I tried reinstalling the NIC, but I’m still getting the error.

This really baffles me, I’ve tried pretty much everything I can think of as well as the suggestions you’ve posted, but I still can’t access the files on it. I’ve tried opening the shares via the dashboard but that doesn’t work either, that just opens the “My Documents” folder.

Have you tried connecting the my book directly to the computer that doesn’t recognize it? You can also try to map it using the IP number.

I manged to solve it, I tried connecting to a user share via the cmd window using the IP for the drive, which I do believe I’ve tried before, but maybe I’ve tried connecting to the wrong share before or something. I just hope I won’t have to do this after every reboot, although I suppose I could just make a .bat for it.