Old issue with the file already exist when copying files (creating only 0 byte copied file) is back

When copying files in File Explorer in Windows 10 I am getting information " The destination already has a file named [ filename.xyz]" adn I cannot copy the file, it is just creating 0 byte copy of the copied file. I have admin permission to the share and there is plenty of free space (more than 2 TBs).
I have the latest firmware 5.15.106 on My Cloud EX2 Ultra 8 TB set as RAID 1 (mirrored 4 TB). I also tried to manually install the latest firmware again based on suggestions from old threads.
I cleared recycle bin and did another suggested “solutions” from older threads about this issue. It is extremely annoying issue. Sometimes ony some files from the copied ones are copied and the rest ends with the mentioned error as if the count of files in given folder is limited or so. I tried in Total Commander and there it is saying that the disc is full but that is complete nonsense. It is really showstopper on my end as I cannot copy files from my local PC to My Cloud storage (connected via RJ45 CAT6 cable through Gigabit Asus router). Copying form My Cloud through File Explorer in Windows 10 works perfectly. Just copying to My Cloud EX2 Ultra is an problem I cannot solve. Strange is that in the folder were I am not able to copy the file I can create new document through the right click menu and fill it with data and save. Please help.

Hi @MilanD,

Please refer below link to help you with trouble shooting steps:

Thanks, I opened support ticket. The issue still persists.

Hi MilanD, did you ever get this issue resolved? I’m having the exact problem with my MyCloudEX2Ultra. Thanks