Old 2TB My World Book drive not accessible

So I bought this NAS drive many years ago. Like 10ish rang. It worked great for a long time. Several years ago I stopped using it and unplugged it. I would plug it in every once in awhile when i needed something from it. Fast forward a few years and it gets harder every time for the drive to be recognized do to what i assume is old WD software and newer windows software. I always manage to get it running through after enough messing around. This brings me to today though.

As you can probably guess I finally have hit a road block in being able to get it to show up on my computer. If my screenshot comes through properly you’ll be able to see it’s detected but shows up as a Generic external USB device. Fine. Try to update drivers. no change. Download the WD discovery program for my Win 11 machine. You can see it shows a external drive but i can’t access it. I click on it but nothing happens. I download, install and run the WD drive utilities and as you can see it doesn’t see a drive at all. I’ve done all these same things with the same results on an old win 7 machine as well.

So basically my systems can tell something is there but won’t allow me to actually view the contents. I’ll mention as well this used to be/is a NAS drive but since i’ve been having issues i removed it from that enclosure and connected it to a external case to attempt a direct connection.

Any suggestions would be greatly appreciated. I know if i can finally get onto this drive everything will be moved to something else and this one can be purged forever.

You might want to try to use Linux see if it able to read the data from it.
There is Linux version that can boot itself from an USB thumb drive. Good Luck

I had tried that already as well with no luck. In that scenario it doesn’t show up anywhere that I can see