OK, now what to do with the speed?

Hi there,
I have a cloud EX2 with two Seagate ST4000DM000-1F2168 drives in a RAID 1 array. I need to move from a 1TB external drive to the NAS a load of movies, ( at least, on the last count, over 800! ) and I’m on virgin media (yeah, I know…)
The NAS works fine playing the movies, as a said, I need to move the films over to the NAS.
I put the virgin router (it’s the latest model, the V3) into modem mode, and bought a Belkin Share router and a load of CAT 5E cables, and connected the router to the Virgin modem. However, the transfer speed is so slow, peaking around 2.5Mbps and never going above 3 Mbps. Ok that was wireless, but connecting the laptop to the Belkin router produced even slower results!
Ok, I thought, “it could be the router at fault here”, so I bought another router, a Belkin AC 1000DB 4 port Gigabyte Wi Fi N cable router access point F9K1112uk model. I set it up, and expected much faster speeds. Or so I thought…
I’m now going to buy a Netgear GS205-100UKS 5 port Gigabyte Ethernet desktop switch, which hopefully might see an improvement on the speed. But what else can I do, if the speed doesn’t increase, from the paltry 3 Mbps? Am I missing something here? I’m using a Gigabyte router, a Gigabyte switch and CAT 5E cables, I can only think it could be the cables, but is there something else? I’m beginning to have doubts on the WD MyCloud EX2…
Help!! :disappointed:

Hello there,

If you connect the drive to the computer directly, do you get the same transfer speeds, this could be a good way to narrow down the probable cause for this.

I believe ArMak means to connect the ethernet ports of PC and My Cloud directly with the ethernet cables…

1 Like

Ive drawn up a testing programme to test the speed of the different combinations of the devices ( VM router/modem, the Belkin router, the netgear switch, and the WD Mycloud EX2) There will be results for both wireless and wired, and they will be wired with at least CAT 5E cables.
However, it might be a while over the Christmas break as at the moment the Internet is almost being used 24/7 with 2 teenage kids in the house!
I’ll publish the results here, and move from there…

Very interesting…
For the 1st test, I moved 12.5Gb of data from the laptop to the external drive, using USB 3 cables and produced a speed of 2 mins 44 seconds moving at 83MB/s
However, for the second test, I moved 12.5GB of data from the laptop directly to the WD NAS using the supplied CAT6 cable, and I got a result of… 11MB/s…
Go figure… could that be the bottleneck?

And that test gave me a blistering speed of…19 mins 25 sec…
Faulty NAS I wonder?

I just tried using a CAT 5E cable to rule out any problems with the supplied CAT 6 cable, and again only 11MB/s… I just don’t know what’s going on with the NAS, but it sure identifies the bottleneck!

The Bottleneck causes the NAS drive to move folders at no more that 4.1Mbps… I’m now at a complete loss as to what it is…I’ve tried…
Swiching off the A/V and firewall in case that’s affecting speed.
Connecting straight to the USB via CAT 5E, and CAT 6 as well as the supplied cable that came with the drive.
Swapping hard drives
updating the wireless adaptor
trying 2 routers
putting the VM router/modem into modem mode
phoning VM support to see if there’s a problem with broadband (there wasn’t)
resetting the VM router/modem, the router, and the NAS drive back to factory settings

I’m going to get a network adapter for the laptop, as I’ve discovered it doesn’t have gigabit Ethernet ports… If that doesn’t help, well, it’s going back, as I’ve exhausted any solutions…