Ok... Media Server -- what gives?


#1

I never use the Media Server, but I try and go through and check things out every time there’s a new firmware.

  • Flashed 1.04.31

  • paperclip reset

  • reset to factory defaults

  • Network Shares still working fine

  • Win7 can “Play To” the WDTV

…so, it seems like things are set and shared properly as they always have been (as evidenced further as you will see)

But, when I click “Media Server” and choose the server from the Win7 PC (default WMP, in this case), I just get the spinning circle, and then after about a minute, it times out and “Can not connect to network”.  Well, 29 times out of 30 I just got the spinning circle – one of the times, the Folder choices came up, but when I tried to click on the “Folders” folder (or any others), _ then _ I got the spinning circle and the “Can not connect…”

Since I’m sure all the settings (WMP, firewall, router, WDTV Live, Networking, Sharing, Homegroup, Media…) are all set properly, and they’ve all been triple-checked, and since the WDTV did momentarily connect to the WMP server _ once _, and since WMP can “Play To” the WDTV, it would appear as if WMP simply isn’t responding to the WDTV in a timely fashion, as opposed to some setting set incorrectly.  The box reponds to the Samba connections pretty instantaneously, and 720p and 1080p files will “Play To” the WDTV with no stuttering, (and the PC and its ethernet port aren’t knowingly busy with other tasks), so it would appear that there’s no reason for WMP to not reply faster/sooner to the WDTV enquiries.

So, the $64,000 question is why is WMP not responding to the WDTV?

And the million-dollar question is: how do I fix it?

Any of you gurus have any bright ideas?

As I said, I never use the Media Server to play anything, but I’d like to get it working so I can continue to check “yep, still working” with future firmware updates, to know if something does get broken at the WDTV end.


#2

Have fun trying, very hit and miss with WMP, had it working well for a while  - then it just started to play up again.

list here of what ports should be open LINK

All other media servers I’ve tried worked fine, so it has to be WMP ???


#3

markinuk wrote:

 

it has to be WMP ???

Well, it doesn’t have to be WMP, per se… but all network-related problems I’ve had have always been at the computer’s end – usually Windoze is at fault in one way or another.  And I quite deliberately never blamed the WDTV for my current woes.

Usually the WMP issues that cropped up in the past were fixed with a simple reboot of the PC.  But that hasn’t worked this time.

Even though I have “Automatically update media files” turned off in the settings, WMP could be checking the library in the background, or doing something else stupid, which prevents it from responding soon enough.  I’ll leave the PC on overnight, and try connecting the WDTV to the Media Server again in the morning and see if it still times out.  Surely, by that time, WMP will have finished whatever the heck it is that it’s doing in the background that I never asked it to do.


#4

Never had much luck with WMP in the past.

If it still doesn’t work, try TVersity or Serviio or pretty much any other Media Server, just to be sure it’s WMP at fault.

I’ve never had any trouble connecting to Twonky on my NAS, even when network shares have been down.


#5

if you do leave it going all night, maybe WMP may have finished not working. lol

just checked mine and have the spinning wheel, tried network shares - all ok, went back to media server got the folders up - pressed all video and was back to the spinning wheel, pressed home button, tried again and spinning wheel again.

Started SERVIIO running and  it was working straight away.


#6

There is known issue with streaming video using Windows 7 networking. It varies from box to box. The issue is the way Microsoft implemented the networking in Windows 7. (cripleware is the best description) To get media streaming successfully to the WDTV Live box you have to bypass the Windows 7 networking software and use DLNA media streaming software. All the DLNA media streaming software on the market, free or paid have a degree of problems. Try them all and use the one which works on your computer. Serviio seems to work reasonably.


#7

thepanoguy wrote:

To get media streaming successfully to the WDTV Live box you have to bypass the Windows 7 networking software and use DLNA media streaming software.

I’ve found the opposite… Net Shares has always streamed beautifully for me, even in 1080p (granted I don’t have any 80mbit files that would exceed the Samba limit).  It’s the DLNA that I’ve always found to be tempermental and limited.

Now, WD could have broken something inadvertently, so that the WDTV no longer connects properly to WMP (since it behaves identically for markinuk), but I’m still leaning towards WMP being the culprit.