Oh well posting up a bug report here

Don’t mind me… just posting up something that I think is buggy…

  1. turning led off, does turn them off… until the cloud probably goes to sleep, or something… because later on in the evening the leds are back on and I mean full on without ever going back to the slow blinking lights. So I don’t know if the cloud never goes back to sleep or it is just the LEDs on constantly (both clouds one has cloud access on and the other one doesn’t). So I had to turn on the LED to get back the normal cloud LED operations.

I was hoping that with the LED off it would hide the fact that my Cloud never really sleeps.

  1. the scans are complete or should be by now after almost 2 weeks of scanning 750,000 entries. The Cloud does fall asleep for probably up to 3 hours at a time but wakes up throughout the day and you would hear this click every few seconds and it does this for hours at a time, sometimes all through the night. I really think that this should be fixed.

  2. sleep… so close. I mean if you took out the cron and stop having it do various things through the day and night, the Cloud has the potential of sleeping. With Cloud access off, even with the cron, it seems to be sleeping most of the time, but it would be nice to have a weekly cron instead of a daily cron.

With cloud access on, once the cron wakes up the cloud, it would go for hours with this click every few seconds and it is really driving me bonkers because my place is a “mac place” that you can hear a pin drop; no gaming pc with turbo fans to hide the drive access here.

Other than that, an almost perfect NAS… so close…

You need to check the access time on /tmp/browse.dat and /etc/samba/smbpasswd. During my testing of the sleep problem. I found that under certain conditions these files would get accessed quite frequently. I reported this problem to the samba group. It was supposed to be fixed in a later version of samba. But WD still uses the old version. That is why we started using the
mount -o remount,noatime,nodiratime /dev/root /
Not sure if this also will work on the gen2. But it does work on the gen1.


if you wish to participate in debugging the gen2 and provide insightful solutions, please re-buy the cloud and proceed with hacking like a normal hacker would :stuck_out_tongue:

You cannot 3rd party hack

tonight after a whole evening of tictaaaaaac… tictaaaaaac… I decided to go in again and stop all services and… killall crond of which I watched with satisfaction the death of crond from ps -ALL.

I did this on both clouds…

but on the one cloud that has cloud access ON and… is mapped to my sleeping Mac with samba… it continues to ominously continue to go tictaaaaaaac… tictaaaaaaac much like a very slow clock… or writing to the hard drive every few seconds.

The other service that we knew to do this was … restsdk-severd but even that service was stopped.

So something is writing to the drive… but… here is the interesting thing… the drive went to sleep even though that tictaaaaac-ing was going on… all of a sudden it went quiet… and stopped… and it slept…

Cloud access is still on, but I stopped all the services after starting the cloud access… now I don’t know if the services will restart if I just access the cloud remotely… but I don’t think so on a few test that I did.

The services should stay off until I restart the cloud access off then on, or off then use the cloud app to turn it on.

Lets hope this works… then I can call it a day… and tote this to be the new procedure for the gen2 clouds.

My Cloud is finally sleeping… Truly… Deeply… Sleeping…

Make sure cloud access is on then
ssh into the device and
killall crond
/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop

Now this works fine after the scan is done but I don’t think it works before the scan has completed because of monitorio.sh which sets a flag in /tmp to indicate that hard drive size has changed and thus to run the scans, which means the drive doesn’t sleep even though the scans are not running. This was my observations when I first got the drive.

It may be possible that Samba is making that click… Click noise because of my Mac mini which is used as my entertainment center and has a samba mapping to the “my Cloud”. The Mac Mini seems to wake up at around 10’ish too somehow picking up the bad habits of the cloud.

Anyways, the above must be done every time you reboot the Cloud, so it might be best to put it into a script and kept it in your shares.

So that really wraps it up for now…

edit: just moments after I posted this, the drive is awake. The mac mini with the mapped cloud os still asleep. No other access to the cloud has occurred this morning. I was writing up this post on my iPad and now on my macbook. No mappings. No Cron and yet the drive wakes. hopefully it will go back to sleep, but I really hate the fact that we have no logs of anything. infuriating and perplexing especially now with gen2 that we are really helpless to do anything.

edit2: it is back to sleep. This is deja vu as I spent last summer doing the same, keeping an eye on the cloud all day… and not having any access to the files that are stored on them.

just discovered that my Mac mini no longer had the cloud mapped as a drive. Anyways I remapped the cloud drive and then ejected the drive to ensure that the drive doesn’t have any residual mappings if there is such a thing.

The clicking continues whenever the cloud is awake. So I don’t think it has anything to do with Samba since nobody is mapped to it.

This clicking is disconcerting…

But you won’t look at the two files I mentioned.


I still think you should have your own cloud so you can swear at it and demand answers from it rather than from another angry user on the forum.

anyways, the files don’t exist in the new gen. here is a screen shot of tmp

Also the samba problem is more of a wake up after 5 second sleep fix that never really got fixed. No idea if it is samba or something else but after I copied a bunch of stuff to the hard drive today, it took (I think) 20 minutes before falling asleep again, then woke up minutes later when I wasn’t looking… It is that feeling that you picked up some garbage in your house and threw it away… to find more garbage strewn around… it is that kind of feeling… I still think it has to do with monitorio.sh because it checks if the hard drive changes and flags the scanner to scan.

This other problem is new, the tic tac sounding like a very slow train (writing to a track click clack every 2 seconds) it is definitely a write type of noise much like that restsdk logging… so I’ll just have to keep looking for the service or something that is causing this noise on days when I have nothing else to do.

Too bad you cannot participate…

One of the things that i did when looking into the sleep problem. I stopped samba. After which it stopped writing to disk. It seem to me that when I did have the gen2. I didn’t see monitorio.sh running. Because there were no messages in the log about wake ups.


so here we go again… I stopped samba the last time too… and I just spent the last hour doing your hacking which I promise not to do again… I spent the last hour looking for a way to start and stop samba…

and I after typing in a long script for /etc/init.d/smb which I found didn’t work because we didn’t have killproc in bin, I accidentally typed smb and lo and behold smb has stop, start and restart.

So finally I went ahead to stop SMB… to find…

the tocking continues… it isn’t samba…

So now stop throwing out all your samba theories… because nothing is connected via samba, I even stopped samba… and the “tock” continues.

I am not spending another hour on this…