Oddest problem I've encounterd with an external usb3.0 GTECH drive


#1

This problem is confusing me like mad. I bought this drive: G-Technology 1TB G-DRIVE Portable USB 3.0 (MFR: 0G02723) to use as an external drive to backup images on a road trip. I tested it on my desktop workstation, works perfect. Decided to test it on my laptop since that is the interface I will be using to copy from SD cards to the usb drive and it fails practically every time I try writing a file that is more than a dozen megs to the external drive. If I have files on the drive, I can copy them from the external drive to the laptop fine, It’s only a problem when I try copying files from the laptop to the GTECH drive that the error occurs. It is not the laptop, I can use my sandisk extreme 480gig SSD drive on my laptop and copy to and from all day with no problems. What it the most confusing part is when I plug a USB “safety tester” into any one of my laptops usb ports, then the GTECH drive into the voltage/current tester, the files transfer perfect everytime from the laptop to the usb drive.?

Does this make any sense to anyone? I’ve tried doing what numerous web searches have suggested, using chkdsk to evaluate the drive, its a fine drive, works perfect on my desktop and when plugged through the usb tester. I’ve booted my laptop into safe mode and tried the transfer, still no go. I’ve tried multiple cables, as pictured above, I am using the cable from the sandisk product. I can’t figure out why one usb 3.0 external drive reads/writes fine, while the GTECH usb3.0 does not work properly on the laptop, and works fine on the desktop. Both the laptop and the desktop pc are 64 bit machines running windows 10 pro. Any suggestions would be great, I am leaving on a road trip in 2 days and this GTECH drive was going to be my storage backup for all my SD cards, and I really don’t want to be plugging it into my laptop through a usb tester just to be able to write images to the drive. To recap, I have tried every one of the 3 usb ports on the laptop( which is a Lenovo thinkpad that is about a year old with 16 gigs of ram) and none will successfully write files to the gTech hard drive, I have tried safemode, and more than one cable, all do not transfer properly. At one point I tried copying files directly from one of my SD cards that I put into the laptop’s internal SD card reader, onto the gTech drive through the laptop and that copied about 90% of 25 gigs of data before the same error message occurred in the above image. Also have tried reformatting the gTech drive as both NTFS and exFat and it still has the error while writing to the GTECH drive, only while plugged into the laptop.

Thanks for any help.

Eric


#2

UPDATE: after some more testing, I found that plugging a usb 2.0 extension cable into my laptop, and then plugging the GTECH usb3.0 drive into the cable, now files can be written fine from the laptop to the external GTECH drive.? Makes no sense to me, but explains why the usb safety tester made it work since that is a usb 2.0 interface. For some reason, slowing the connection down to a usb 2.0 seems to make it possible to write to the drive. Can anyone think of a reason, and a fix to this problem.? I simultaneously connected my sandisk 240gig SSD that is a usb 3.0 interface to my laptop while files were being copied to my GTECH drive, and the files copied to the sandisk drive at a sustained rate of around 170MB/s as compared to the slowed down usb 2.0 speeds of 35MB/s for the GTECH. So there are no problems with the laptop being able to transfer at usb 3.0 speeds. The only real differences between the sandisk external and GTECH external is that the sandisk is SSD and the GTECH has an internal drive that spins at 7200 rpm. Worst case scenario, I bring my usb 2.0 extension cable with me on my road trip to still use the GTECH drive as an extra backup if all my other media storage gets filled up. At least when I get home and plug the GTECH drive into my workstation, It will transfer the image data at usb3.0 speeds.


#4

Did you get an answer to this?

I’m a tech guy who was approached by a friend who was having the same problem with his new Laptop and the same drive you mention. When we plug it into the USB2.0 port, all is well. As soon as we pop it into a USB3 port, it fails to write everytime; although reading works in both ports.

Further to this, my laptop works fine from either USB2 or 3 for Read and Write.

Why would his laptop fail like it does?? I’ve checked all drivers are up to date on his machine and compared them to mine and we are both similiar; although I have an ASUS TP550L and he a hp-14-bs0039. Both running Win 10…

Any help, thought or fix would be appreciated

Kind regards

Carl


#5

Hi, its been a long time since i posted this, but if i recall the problem was with the usb chipset that is in my laptop. I think my laptop has an intel chipset and my workstation is an asus motherboard that uses a different usb controller and that was the problem. Again, its been awhile since i looked into it but pretty sure i had found articles and posts from others saying its the intel chipset and that intel has known about it for a while and never did anything about it.