Odd issue


#1

I just bought the WD Live HD Media player and am pleased with it, now that I got the right dongle (grrr on the limited selection there).

I can access the YouTube, i can access my media server and i can access my network shares, no problem.

However, for some reason, when I try to play .mp3 through media server, I receive the “no content in this folder” message.

There IS content in the folder, since I can play it when I browse there through network share. I can also “play to”, with no problem. Furthermore, I can play videos or photos through media server… just not music???

Lastly, I know my .mp3 folder is set up properly because I’ve been streaming through WMP to another device for years, without a hitch. I have confirmed that the WDLIVE device has streaming allowed through WMP (default setting for all formats). 

I’m running the latest firmware (I installed that before I installed the network) and I power cycled several times. I don’t want to start screwing with permissions because they must be right, as demonstrated by my access through network share.

Any suggestions?


#2

This sounds like an issue that was posted before, don’t know if it was you though. Unless you start out from Home screen selecting music, all folders will not display music files and will give the “error” you experienced…  Al


#3

Well, it wasn’t me that posted since I’ve only been up and running for a day. I also couldn’t find any relevant posts, other than those I’ve already tried. 

Unfortunately that isn’t the issue, since I do start from (home) Music.  I don’t have to do that to play any media through network shares though, fwiw.


#4

Bump?

Still no luck over here. Network shares work fine but I cannot play music through media server. 

Doesn’t make any sense… grrr… 

HELP??!?!?


#5

When you say can’t play any music: is it that no music files are displayed? or you play a music file and no sound comes out? Do video files play well with sound? What type of music files do you have, and what are their file types (e.g.,  .mp3)?  Do the music files play in your pc?   Al


#6

Hi Al,

Sorry that I wasn’t more specific.

I get the familiar “there is no content…l” error when attempting to play music, so indeed, no files are displayed. I have mostly .mp3 files, and a few raw .WAV. The error pops up almost immediately - as if it’s not even scanning my “MP3” folder, which has 40+Gb of music.

Video files play fine. I can stream DivX through media server with audio and video. I can also stream HD video using network share (i.e. .MKV files don’t  appear  through media server).

Again, I can play all my music files in this same (MP3) folder if I access it using network shares. There are drawbacks and shortcomings to doing it that way though, so I would like to utilize Windows Media Server capabilities with the WDLIVE, at least for my music.

To answer your last question, yes. My MP3 files play on my PC, they play through WDLIVE’s network share, they play via Windows 7  “Play To”, and in fact they also play on the D-Link Wireless Media device that this WD Live was intended to replace.

In other words, I am certain that all of my settings for sharing and streaming are correct, since all of my media is available using workarounds.


#7

So what it comes down to is some incomparability between your media server and the WDTV Live.

Have you tried to add a new test folder to your media server with say one or two mp3 in it to see if the WDV will play those.

I understand that your files play OK via network shares and on your computer etc but when troubleshooting it is necessary to have a completely open mind.

Also I know that you said that you power cycled but it may be beneficial to do all the things listed on post 2 of the thread below.

http://community.wdc.com/t5/Firmware/1-02-21-network-amp-sub-problem/td-p/24234

After an upgrade the WDTV sometimes gets a bit screwed up and needs a good reset.


#8

Hi richUK,

Yes, I have already tried making temp folder, shared them and dropped a few mp3s in there and encountered the same problem (no content). Videos work fine this way, once again.

I also followed the 3 power cycle procedures (again), to no avail.