Obviously there's an issue affecting access to MyCloud

I’m seeing more and more a common thread here, and it mirrors my own: access to MyCloud is degrading after a restart, to either a slow crawl or stopping altogether. None of this happened but a week ago when I started noticing there was an issue. I think it’s clear that there’s something affecting the WD side of things. We need a firmware update or some official statement about what’s going on.

1 Like

It’s like night and day. Thanks! Finally able to try to figure out why My Cloud is acting wonky. I think it’s the Firmware, but at least now I can work with it without going crazy.

Okay, here’s the thing. Access to the Dashboard was super fast, faster than it has been acting lately. But the network map to the drive was down. I restored that and now the Dashboard is slow as molasses, to the point of it never loading. I really believe this has to be Firmware related. That’s the only thing that has changed. I could be wrong, but this is all just so odd to be happening lately.

What firmware version are you using on your My Cloud? Are there any other devices using the My Cloud (like streaming media or copying files to/from the My Cloud) at the same time you see the slowness or sluggishness?


Nothing is using it for streaming. I rebooted this morning and the Dashboard is fast again. I’ll map the drive manually in a bit, but it still won’t show up in the network, anymore. This has been constant work for the past week or so.

EDIT: As has been happening lately, I slowly lose access to My Cloud as time goes on. A reboot will allow me access and then it’s downhill from there. I’ve seen this problem talked about before. The thing is, this has only happened since an update to the firmware. I don’t jump on an upgrade right away since it rebuilds every time, and if it ain’t broke, don’t fix it. But I did update, and this has been happening ever since. The new thing is that it’s not showing up on the network anymore. This thing worked pretty much flawless until now. I will leave it alone for a day or two then get back to it, but it’s still a load of nonsense.

EDIT #2: It’s showing up in the network (inconsistently) but the shared folder isn’t showing up in Map Network Drive. Also SmartWare says no writable partition until I right click and open manually. MyCloud is there, it just isn’t working like it used to. Also, the android apps don’t auto-backup anymore. I can upload through WD Photos but see none of them while using the explorer. My Cloud app can explore folders but won’t back up automatically.

EDIT #3: I can now access the Shared Folders but the Photo app on Android still doesn’t upload or show all photo thumbnails. Did the cache refresh on the app and now I am unable to access the device.

I’m ready to move to another product. This is just too much work.

Edit: Can’t even access the drive, anymore, except through explorer, and that is really, really slow. Can’t load the Dashboard.

Edit #2: Now it doesn’t show up at all, anywhere. I guess I’ll report back in a few days when it decides to work for a few minutes.

Have you contacted WD Support to see if the drive can be RMA?


Honestly I’d just trash the thing. And I think it’s the firmware because that’s the only major issue. I’m going to give it a couple of weeks then I’ll downgrade the firmware before I move on. It’s worked fine more or less until recently, diagnostics are all okay when I can actually run them, but it’s a pain when there is a problem such as this. Hopefully the Firmware downgrade will be the furthest I’ll have to take it.

MyCloud is still acting strange. I think the issue is caused by one particular issue: If I map the drive, the Cloud can’t be accessed by wireless devices. If I connect wirelessly, say to back up photos or anything, I can only map the drive by putting in the info myself, as it won’t show up in the network. I believe this is where it is running into issues since I updated the firmware.

It sounds like a network problem to me, rather than a problem caused by the MyCloud.

I have no problem with mapped drives, and accessing my MyCloud via my wireless router at the same time.

I have two PCs connected by ethernet, which have multiple mapped drives, plus an android media box that is permanently on and connected wirelessly via both smb and dlna. I have two android tablets and an android phone that are also connected wirelessly.

Gen1, latest firmware.

Yeah, possibly. Something definitely changed while everything remained the same. Really, the only thing that’s different is I recently updated the firmware. I also have a lot of access points to my network, but the My Cloud is the only thing that’s been failing. I would think it may be my network because unplugging it for a minute corrects the issue very temporarily.