NTP Issues


#1

I can’t change the NTP settings after updating the firmware.

Current level: MyBookLive 01.04.06

On the System -> Setting page, I’m getting two Notice messages above the main panel, which read:

Notice (8): Undefined offset: 0 [/var/www/Admin/webapp/includes/DateTimeConfiguration.php, line 50]
Code | Context
DateTimeConfiguration::getConfig() - /var/www/Admin/webapp/includes/DateTimeConfiguration.php, line 50
DeviceApiComponent::getDateTime() - APP/controllers/components/device_api.php, line 251
SettingsController::system() - APP/controllers/settings_controller.php, line 30
Object::dispatchMethod() - CORE/cake/libs/object.php, line 116
Dispatcher::_invoke() - CORE/cake/dispatcher.php, line 227
Dispatcher::dispatch() - CORE/cake/dispatcher.php, line 194
require - APP/webroot/index.php, line 88
[main] - CORE/index.php, line 61
Notice (8): Undefined offset: 1 [/var/www/Admin/webapp/includes/DateTimeConfiguration.php, line 51]
Code | Context
DateTimeConfiguration::getConfig() - /var/www/Admin/webapp/includes/DateTimeConfiguration.php, line 51
DeviceApiComponent::getDateTime() - APP/controllers/components/device_api.php, line 251
SettingsController::system() - APP/controllers/settings_controller.php, line 30
Object::dispatchMethod() - CORE/cake/libs/object.php, line 116
Dispatcher::_invoke() - CORE/cake/dispatcher.php, line 227
Dispatcher::dispatch() - CORE/cake/dispatcher.php, line 194
require - APP/webroot/index.php, line 88
[main] - CORE/index.php, line 61

I’ve tried the factory reset, to no avail.

Can someone please verify that it is possible to change the NTP settings from the GUI on this build?

Thanks,

Mario


#2

This works here. I would contact our support team . Make sure you generate a system report to send to them to look at.

Tony


#3

What’s the Web form expecting in terms of attribute format?

IP Address, DNS name, or “server hostname” like what appears in a standard ntp.conf file?

The manual only refers to “the URL address”, and NTP does not have a “URL address”.

Thanks,

Mario


#4

OK, I figured it out.  It’s not exactly a layer8 issue, but not far off.

First off, the NTP server field in the web GUI is expecting a FQDN, like time.nrc.ca.

You can screw up the NTP setting on the NAS using Chrome for Linux. (I’m on Ubuntu)  If you try to set a new primary NTP server using Chrome, you will get the 5657 communications error.  At that point, you need to do a partial factory reset to restore things to the way they were.

****USE FIREFOX****

So, the fix for this was for me to simply use Firefox to configure the device after the factory reset.  Using Firefox, I was unable to hose the NTP settings at all.  Switching back to Chrome, I hosed the NTP settings again, and needed to do another factory reset.

So, once again, use Firefox.

This behaviour is reproducible, and here’s how.  Back up your data.  After doing a short factory reset, go to the NTP settings using Chrome, and try to enter a new primary time server.  Enter “server time.nrc.ca”, which is an incorrect value for this field.  Hit “Save” and you will get the communications error popup.  Navigating back into the Settings panel, you will see the two “Notice” text fields at the top of the page as noted in my previous post.

My problem is solved. 

Mario


#5

Mario,

I’ve had the same issue for the past two to three weeks.  And I use FireFox, exclusively.  The partial reset didn’t help, but the full factory restore did - until I tried to change the settings again and got the same communication error.  And once the communications error happens, *all* the NTP hosts are gone.   I’ve been back and forth with tech support a few times and they concluded that I needed to do an RMA and get a new drive!  What I don’t know, at the moment because I’m typing this at work, is what my current firmware version is.

Did you put “server” in front of your hostname, or just use the full hostname?

Also, what version of  Firefox do you have?  I’m not running the latest version yet due to some add-on incompatibilites, but I’ll upgrade if it fixes this issue.

Joe


#6

That’s correct - once the communication error occurs, all the NTP hosts are gone.

Support told me to do an RMA too, but I’ve since resolved the issue to my satisfaction.

No, I did not put the “server” keyword in.  Just use the FQDN (Fully Qualified Domain Name), like “time.nrc.ca”.

I’m on Firefox 3.6.16 on Ubuntu Linux.

I’m guessing that there is some javascript that is particularly fussy about browser types.

If you’re on Windows, another option is for you to try IE, because that’ll probably have better support from WDC.


#7

A tip…  Find and take a copy of every configuration file on the NAS while the NAS is working correctly. Makes it a lot easier if something screws up some configuration.


#8

I ran into the same issue using Chrome for the Mac.   The solution worked as well.   Quick Factory Restore and use firefox to change the settings.