Notification emails - not sent according to RFC

The notifications/alerts are sent through servers notify.senvid.net (probably belonging to WD). But they seem to not comply with RFC http://tools.ietf.org/html/rfc821.
They use the keyword ‘from’ where ‘mail from’ is expected. Some receiving mail-servers reject such connections, like the ones of my hoster do (see example below) Probably more other users do have the same problem.

WD please fix this.
Regards dewege

Example (bad):
~# telnet localhost 25
Trying ::1…
Connected to localhost.
Escape character is ‘^]’.
220 server37.hostfactory.ch ESMTP Postfix by hostfactory.ch
helo notify.senvid.net
250 server37.hostfactory.ch
from:nas.alerts@wdc.com
221 2.7.0 Error: I can break rules, too. Goodbye.
Connection closed by foreign host.

Example (good):

telnet localhost 25

Trying ::1…
Connected to localhost.
Escape character is ‘^]’.
220 server37.hostfactory.ch ESMTP Postfix by hostfactory.ch
helo notify.senvid.net
250 server37.hostfactory.ch
mail from:nas.alerts@wdc.com
250 2.1.0 Ok

Not sure I follow.

I get notifications from the MBL just fine.   That means that the receiving server is fine with the email transaction.

Are you saying that the RELAY isn’t working correctly?

Hi TonyP1234

On most eMail addresses I’m also getting the alerts just fine. To me it seems that some receiving servers are more strict on RFC rules and want the sending server to follow them exactly (like the one of my hoster)

The following was the log-entry generated by the receiving server (got that from my hoster)
END-OF-MESSAGE from notify.senvid.net[198.107.148.103]: 5.7.1 Command rejected; from=nas.alerts@wdc.com to=Net2@graff.ch proto=ESMTP helo=<notify.senvid.net>

As I understand the SMTP, there should be a command MAIL with an argument FROM. But the log entry says that it only received FROM, which is not a command by itself.

Sorry, i’m not really deep in mail protocols

Dewege

I’m having the impression that my hosters support wasnt reading the logs carefully …

Looking at a notification that reached me through google-mail I see the following error message in the headers:

Received-SPF: fail (google.com: domain of nas.alerts@wdc.com does not designate 198.107.148.103 as permitted sender) client-ip=198.107.148.103;
Authentication-Results: mx.google.com;
       spf=hardfail (google.com: domain of nas.alerts@wdc.com does not designate 198.107.148.103 as permitted sender) smtp.mail=nas.alerts@wdc.com

So the problem seems to be SPF: restrictive servers probably reject mails from IP-adresses that are not authorized to send mails for the wdc.com domain.

The mails are sent by notify.senvid.net and WD should simply authorize this server to be allowed to send from wdc.com.