Nothing! Just nothing!

I have been wanting one of these for a while - but I just didn’t do my research.

Today I purchased a WD Passport Essential 320.  I had to travel 60 miles to get it.  I couldn’t wait to get home to start using it.

When I plugged it in…nothing.  It’s just sitting there with a light on (steady).  My laptop (Vista) tells me the hardware is installed and ready to use…but there’s nothing there!

No drive, no software, no manual, no nothing.  Just a little black box with a pretty little light.

120 miles round trip for this.

I’ve done some reading online and it says to try your blackberry cable.  I did that.  It says to uninstall your USB controllers and then Action/search for changes.  I did that.  I tried all of my USB ports, nothing.  This is a big let down.

I’m a reporter with a newspaper.  I’m going to let my readers know about this one.

120 miles again tomorrow to return the product.


Did you ever try Disk Management to see if the drive showed up there?  Did you try it on another pc to see if it showed up there?  Did you try it on another USB port?  Were you connecting it to a hub?  Were you using another longer USB cable?

A couple of things you should consider:

  1. It’s definitely possible that the drive could be bad (manufacturing), or damaged (shipping or handling).
  2. Your laptop may not have been able to put out enough power through the USB port to power it.
  3. Have you done all you Vista updates.  There were some major Vista and USB connection issues when Vista first came out.

Just some thoughts.

‘‘I DISAGREE’’   I Dont Believe that it Could Be a Defective Drive …

Could Be the Following :

  1. Drivers Conflict

  2. HD Not Getting enough Power

3.Or Any other Issue that Could Be Solved Real Quick , So i Will Recommend You to Contact Western Digital Tech Support  and You will see that the You will Be Resolve, Click The link Below …