Not working

When I move files to MyPassport, it starts ok and after writing just some of the data, stops and give me this message:

Could not find this item.

This is no longer located in Computor.  Verify item’s location and try again.

I’ve tried again and again.

I have two of these and my computer will list files that are not on the drive that is plugged in, but the files are empty, of course.

The whole time I’ve owned these, they have occasionally given me these problems, but now they are completely useless.

Try renaming the drive and changing the drive letter

windows tends to have problems when two similar drives are connected

do you have the same problem if only one drive connected? 

There is a more permanent fix see post 11


Joe S,

This worked when I changed the name as instructed, but the next time that I plugged the drive in and started to move files, it does the same thing.  Does this mean that I have to change the name every time that I plug it in to my computer?

I just went through the steps to rename (uniqued) the Passport as I had before and then went to move files.  It didn’t work this time.  I get the same message that I quoted in my first post and while I can see my file structure, the files are empty.

I have to say that this seems like a rather stupid bug to make hard drives completely useless and a waste of money.