Not showing up

hello I am using WD my passport 1 TB for about 2 years and last couple monthes there has been a problem that I will explain: when I am using it sometimes it ejects automatically and connects automatically for example I was coping some videos from WD driver to my laptop that it unconnected from and the error says the file does not exist that it means there is no connection and it connected without my Involvement.while coping my vids(about 100GB) this happened several times and at the last time external hard disconnected(ejected) automatically but never connected!!! I tried fixing it by unpluging and pluging it but no answer!! i have a my book 2TB too so i tried by its cable to test if problem is from cable or not T but it didnt work SO now there is NO sign of my passport in my computer but in device manager driver is shown by a sign of yellow error sign PLEASE HELP ME!!!


Try some basic troubleshooting:

1- Disconnect the drive from the computer and restart the computer.

2- If the computer is a desktop, connect it on the back USB port (directly to the PC, not through a hub).

3- Make sure you hear the connection sound windows makes when recognizes a USB device.

4- Go to "Disk Management” to verify if the drive shows up there.

If the drive shows up in disk management but it is not seen on Computer, then it means the partition is corrupted and you will have to format it in order to use it again. Please note that formatting the drive will delete all data stored on it.

Hello Dear Hamlet

1-I have tried it several times in several pc and laptops

2-I dont have hub and I connected on all back and front usb ports

3-there is sound but no sign of drive

4-when opening Disk management with my passport connected it shows (((connecting to virtual disk service…))) but the page doesnt load but when I disconnect my passport the page loads .tdisk management either hangs up((NOT RESPONDING)) or loads without showing my passport.

Here are some screen shots