Not showing shares

The WD photo app is working, But the WD2Go app is not. Connection is made, but it will not show any shares. Tried it with different users, tried it with the Ipad or Iphone. Both are not showing any shares. Upnp is activated on the router. Any suggestions on what to try? What ports does the application use? Because I have a 2nd NAS where I redirect some ports. But since it can detects the drive I can not believe that portforwarding is the problem here.

The latest firmware update for the MB Live (02.10.09-124) allows you to select the ports, what if you update and set the ports manually?

Hmm, may be I am a bit blind but where do I find the page to set the ports? And yes, I have the latest firmware.

It is not under settings/Network where I would expect to find it.

I didn’t update my MBL since mine’s stable so I don’t exactly know =/

It’s on the release notes, so why not checking with WD the exact location?

The sollution was that the application did not show the standard shares. When I created a new one and made it private suddenly all the other shares also popped up in the app.