Not seeing all of my video files

I just got my WD TV live and set it up. Things seemed to be going fine, it saw my Seagate Go Live Home Flex network hard drive, but when I tried to look at the videos on it, it would show me the first set of folders, but then when I clicked down a level (Folder called TV Shows) it would only show me the first folder on that level. Inside that folder are the files that should be in it. But I can’t seem to get it to show me any of the other folders. The files are a mix of avi, divx, etc. It is also showing all the other files in my other folders.

So, it goes Hard drive -> TV Shows -> Cartoons, but on the same level of Cartoons should be many more folders and some video files not in folders. I tried moving some files around, renaming the folder, etc, but the TV Live does not seem to update to see the new names (such as changing Cartoons to be XCartoons).

Tried to contact support/help about this, and I keep getting error messages -_- 

Oh, and I did go through all the updates, and I’m not sure what power cycling is, but I tried the good old unplug and replug it in thing. Should be still at factory defaults I’d hope. 

how are your shows named?

sometimes the naming structure and the SMP don’t work well together.

oh and pulling the plug and then plugging it back in is power cycling, so you’re ok there.

The files are named all sorts of different things.  Whats weird is how it won’t update the files it sees either.  I mean, I changed the name of the folder it is seeing, and it won’t make the change when I search on the WD TV Live.  It sees all the other folders and their files, but just nothing under TV Shows, besides one folder and its files. 

You need to rescan the drive if you make changes to a NAS share.

OPTIONS – RESCAN.

How do I rescan the drive?  Do you mean the options button on the remote? If I push that, nothing appears to happen, no options menu comes up. 

I tried resetting the device, and after resetting it still sees the hard drive with only the same folders as before, and with the old name of the folder, not the name I have since changed it to. 

Are you using media library? If so select the folder and press options on the folder.

I think I am using Media Library, and I am trying to press options and every menu I can find, but I don’t see anything along the lines of rescan. 

Is your content source set to “My Media Library” or “Network Share” or “Media Server?”

I am finding the content under Media Server… it doesn’t show up under any of the other options. 

The media server needs to be rescanned, then. The WD will only display the files the media server offers.

*sigh* and I can’t seem to get it to rescan.  I’ll keep poking around at it then.  At least I think I know what I’m looking to do now. 

Well, I still don’t know what was going on with the media server, but I called up tech support and between us we figured out that my drive which should be on the network was on the wrong work group, which is why it wouldn’t show up under network shares. No idea why it would be on that other work group, but now everything is talking to eachother!