Not retrieving US apps

I have 3 of these units and all of them work except for the most recent one I purchase.  Before I return it I wanted to trouble shoot it a bit more.


I live in Canada and have a Hulu Plus account.  I put in my US dns address and it is suppose to update my “Services” according to location.  But for some reason the unit is not reading my new location when I put in the US DNS address.  When I configure the unit automatically it will say my current location of Canada. 

So I did a factory reset same thing nothing.

So I was going to reinstall the firmware incase something went wrong during the two firmware updates it requested when I first bought the unit last month.  But I can’t not reinstall it.

I downloaded a roll back firmware driver and named the version number higher than that of the current firmware but the unit does not detect the files on the thumb drive.  When I plug in the thumb drive it says compiling files on usb drive, but nothing.

Any other help would be appreciated 


What WD model do you have?

What firmware is on the player at the moment and what firmware are you trying to install?

I’m not at home right now.  But from what I can remember it’s somthing like BHG7000nbk but can’t remember exactly and the firmware from what I can remember since I had to change the ver number I think 1.16 something at the end.  Latest version.

I was trying to install the latest one from this site on the right hand side 1.15.10

If your player is the WD Live streaming gen3 version and you downloaded the rollback firmware from the link you posted then you don’t need to edit the ver file. The firmware name will have rollback in it which means that its designed allready to rollback.

Thanks.  Not a good move on my part.  Changed the version number back and it detected the fw.

But still no cigar.  I flashed it thinking it would fix the problem.  It brought it down two versions.  Changed the dns address  to the US dns, still nothing.  No hulu

Don’t know what else I can do besides return the unit

Finally fixed it.  What a process.

So a few weeks ago I joined up to and hulu plus at the same time.  Everything was working fine.  THen when I bought this wdlive, usaccess’ dns seemed to be failing me.  So I signed up for a trial of put in the dns from them in the unit, then boom.  Saw everything, hulu popped right up.  Signed up to hulu, put my dns back into place and everything is working great.  Yeah, no rma.