Not recognizing drive

Hi people.  I am new to the WD TV Live Hub experience and I really like the device.  I bought it mainly for compatability with a ton of media formats and because it recognizes a time capsule drive from my macbook, whereas most other streaming media players only recognize, fat, fat32, etc.  

However, I’ve noticed that when I have a USB wifi adapter and my network drive plugged in it take FOREVER for it to recodnize the drive and/or the usb adapter.  Sometimes it will not recognize one of the two devices.  I’ve disable the feature that catalogues the files on my drive and it is still a problem.  I’ve noticed that if I only have one thing plugged in, either the drive or the wifi adapter, this is not an issue.  The drive is a 2tb WD My Book Drive.  I’ve tried using a smaller portable hard drive (750MB, no separate power adapter) that is FAT32 and it has the same issues.

Does anyone have any thoughts.  Despite multiple firmware updates since purchase this issue hasn’t gone away. 


Hello BHS, i am having the same issue and I know tons of others that don’t post here have it too,

I am saving you the raised heartbeat for the private message you’ll et from one of the mods because the message is formatted wrong.

this is how they want it:

copy and paste this below and edit your original post. :slight_smile:

If you are interested what happens with my external HDDs it is reported here

Good Luck!

- Which firmware?
- What happened?
- What were you doing?
- Does this happen every time?
- What hardware and media were you using?
- Did this happen with previous firmware?
- Does power cycling the unit solve this?
- Does resetting to factory defaults solve this?
- Have you tried this on other devices?