Not recognizing CM3

I have a Media Stick with a CM3 installed in it.

I’ve tried on a windows machine, and a RPi3. On each when I start the media stick the RPiBoot never finds the media stick.

On each host machine I did follow the drive steps correctly.

Any suggestions?

Hi, I’ve also found the CM3 to be more difficult to be discovered by RPIboot using same setups where the CM1 was 100%. You might try using a powered USB hub between the media stick and the host computer (and short, low-resistance cable between media stick and hub). Sometimes rebooting the host PC has helped in my experience.

If you (or others) would like to help me investigate this area, please send me an email (dave.chew@wdc.com) and I can send some hardware- CM3, media stick, CM-to-SATA adapter, short, low-resistance USB cable, etc. The raspberrypi.org forum might also have info, but I haven’t checked yet.

Thanks.

Thank you for the comment, this is exactly what i had to do.

I wonder if the CM3 draws too much power from a laptop port? I noticed the Pi3 got a low power warning when the CM3 started up.

Anyways I tried a powered hub and a short cable on my windows machine, but it finally worked on the RPi3 with a different powered hub and cable.

@dwcsjca

I sent you an email. Let me know if you didn’t get it.
I would be interesting in helping if you have any questions on my setup.

I’ve posted on reddit also, and it seemed to get a good response. So you might want to lock down the FAQ’s on this.
Might also wish to sell a short cable. I found one nearly impossible to find.

Hi, sorry for the delayed response, and thanks for relaying your experience and fix to the communities! You’re right, the Pi3 appears to pull noticeably more current than previous generations. In my experience, even CM1 was iffy- I would need to use a powered hub or a short cable on a USB3 host port to get reliable results.

A custom powered USB cable (similar to how our PiDrive Cable powers the PiDrive) would be the most certain solution. We’ll work to make this happen, but it may take some time to tool. We need to find a low-mid volume rapid-tooled cabling vendor for projects like this.

It would be good to understand the voltage drop on the USB 5V for different setups (with and without hub, long/short cable, etc.). I’ve used some relatively inexpensive in-line USB DMM’s but I don’t know how accurate they are or how much they may contribute to the voltage drop. I’ll try to do some research and see if there’s a good way to do this (I’m not an EE, which may be obvious!).

If you can provide details of the equipment setup that’s working for you (i.e. hub type/mfg, host PC info, USB2 or USB3 host port, cable length and mfg), that might help. A photo of the setup would help too. If you think of experiments and would like to test additional product, email me and we’ll try to get you set up.

Thanks!

Happy to help out. I know these products are new and experience helps.

I tried a bunch of setups because I wasn’t sure if the hardware was the problem or if I was just doing something wrong.

First attempt was on a newish Dell with Windows 8.1. I was using a 22inch Raspberry Pi power cable with inline switch. I use it for all my other RPi’s so I figured it would be fine here. It never connected.

I then tried an older Dell laptop with windows 7. The same cable above didn’t work.
Then I tried an Anker Ultra Slim 4-port USB 3.0 data hub. http://a.co/7IUqYzR and it did not work. This is my go-to powered hub for my Pi Zeros.

Then I moved to my Raspberry Pi 3. Its currently setup with Rasbian Pixel and is running as an FTP server in my house. So it has a different powered hub already connected.
First I tried with just the Media Stick plugged directly into the Pi’s USB ports. I got the “low power” lightning bolt on rasbian when I powered it on.
So I moved to the USB hub. This one is a Tendak USB 3 hub http://a.co/f77ycjg. It was powering a USB HDD at the time. I power the Rpi3 from the “Smart Charging port” as well.
I had tried it a few different times and it just magically worked one time. I’m guessing that the HDD wasn’t spinning and drawing power and the Media Stick got full power that one time. I never unplugged it after that and it went through fine.

I wonder if a Y cable would be a good idea. Something like this: http://a.co/cTGmTv3 It also has the benefit of being short.

I don’t have any need to update my current setup. Its running perfectly and is exactly what I purchased the unit to do.
If you want I can do some other experimentation on this device.

I very much appreciate your offer for other testing equipment. I considered a PiDrive, but I don’t really do multi boots.
The node zero had my interest, I have a few Zero’s kicking around now that I’ve replaced them. If I got my hands on the USB board and a PiDrive(I have everything else) I could build a video recorder or perhaps replace my FTP server, or some other project. But I don’t that would advance your team any further.

Check to see what Monoprice has…or could supply to spec.

Hi ESteid- thanks for the detailed information- very helpful. You might try swapping out the USB power cable with in-line switch with a regular cable. We found that the switched cables have an impact on voltage loss.

I found some powered USB cables on Amazon today (USB OTG) and i’ll try to see if they can be used to externally power the CM while programming. I’ll post an update.

Regarding the Node Zero USB board, send me an email (dave.chew@wdc.com) with your shipping info including phone number and I’ll send you a board. The assembly process is a little tricky (connecting the two USB microB connections between the USB board and the Pi Zero- requires alternately pushing on each connector set until full engagement on both sets). Thanks.

Thanks whheydt, I found some USB OTG cable adapters on Amazon and will see if I can get something to work. Will report back on it. Thanks.

Hi, I used a very short 4 inch cable attached to my Lenovo E560 and flashing was no problem. You can search on amazon for System-S.

Bernhard