Not playing ".mkv" files that it used to play

I have some “.mkv” files that the media player use to play, which no longer play.  Some “.mkv” files play fine, but there’s quite a long list now of files that do not. 

Anybody have any suggestions on what could be causing this? 

I’ve upgraded it to the latest firmware that it offers but I’m not sure about when exactly this problem started.  I just recently noticed it.


Well, considering the last firmware update was almost a year ago, it’s hard to imagine what changed between then and now…  

You could always try resetting it, and if that doesn’t work, roll back to the prior version of firmware that worked.

Thanks for the reply.  If the last firmware was over a year ago then it’s definitely worked since then.  It started sometime in the last few months.  Also, I think I’ve narrowed it down to the media player only not playing 1080p “.mkv” files.  All of the 720p seem to play fine, I haven’t tried all the 1080p and 720p that I have but probably about 20 that confirm this theory.  Also, this part might seem stupid but exactly how do you reset it?  I tried the loop button that you have to push with a paper clip, or other small object, but it didn’t seem to reset anything except for the settings.  Is the device supposed to be plugged into the AC but powered off when you reset it?  That’s how I did it as it’s how I reset other devices with similar buttons like routers to reset the SSID…

It needs to be plugged in, and fully booted up before the RESET button is active.

Have you tried playing them from a USB memory stick just to cut the network out of the equation?

ikbaa - Good call, I did just try that with the exact same file and it DOES play when it’s playing from a USB device.  I have a qualified network setup though, everything is wired in with CAT6 cable through a router with gigabit ports and everything use to work fine.  Is there a setting somewhere that I’m missing?  My kids, six years old, do use this and could have very well poked around at the settings…