Not mappable - FTP server missing folders, in Explorer only "Media Server"+"Storage"

Functionally the My Cloud pretty good now, at least I can use it for streaming and portable data storage, with some reliability. 

Still lots of weird bugs, workarounds required etc. Of the multiple ways you’re supposed to be able to access the My Cloud, not a single one of them works for me consistently. 

I can access the MC in 3 ways presently:

  • Browsing the Twonky DLNA server which shows up categorised in Explorer as “Media Device” and also the My Cloud itself separately under “Storage”. With DLNA folder browsing this works great, however can only read files, not delete/rename etc. This can not be mapped as a normal drive, at least I have found no way of doing so. Right-clicking the MyCloud under “Storage” brings up the selection “Mount Public Share”, but nothing happens. When I’ve had the My Cloud working before, it’s shown up in another category in Explorer and has been easy to mount.   

  • Through FTP. As outlined in the manual, I created an additional user to use for FTP, which is a requirement apparently? I can login and it seems like by far the best way to use the MC - with the functionality and almost the speed of a normal file explorer. Problem is when I log in the FTP program only shows the “Public” and the “FTPuser” directories, there is no way to access other My Cloud data ? 

  • Didn’t work at all for the first several months I had the device, now usually a workable option. But security issues etc. and WD really had their time to fix this now … Opera is the only browser it works with.

… sometimes the desktop app but it is a really substandard piece of work. Why not just provide a stock-standard basic file explorer, it would be so much quicker and more functional ? 

Is there any Windows media software or file explorer-type program that can read the Twonky My Cloud DLNA and open/delete/edit etc. files as well ? 

Solutions attempted:

  • Factory resets (please don’t tell me to do that again… :slight_smile:

  • Mapping directly with ip address e.g., reply is “does not exist”. 

  • Mapping through WD Quickview .The option is there to map both the My Cloud internal disk and the external drive connected to it. Either chose leads to the standard Windows Map Network Drive-window, with the “Folder” field already filled in with the correct adress. Next it says “Network Error - Windows Cannot Access …”. There’s a “Diagnose” choice which does nothing. 

  • Mapping with My Net View and similar software - devices appear but option to map is greyed out and not clickable.

  • Deleting ethernet and wireless in device manager, scanning for hardware changes and getting latest driver from there (BE CAREFUL, I think when doing this you can get yourself in the situation of having uninstalled both your devices to connect to the internet without being able to connect to get new drivers to reinstall…) Tried latest Samsung custom drivers for my PC model, also tried latest drivers from Intel / Realtek for wireless / ethernet card. 

  • All folders/shares made public.



I recommend you contact support directly.

Personal Cloud Support