Not Initialised, not functioning

I know similar cases have come up before, but mine is slightly different.
For some reason i can’t figure out my ext. HD disappeared from the “My Computer” screen after I’d upgraded to Win10. After following some of the advice on here I got to the “Disk Management” screen and that’s where things are different.

With everyone else’s I’ve seen, on this screen there is usually a Gb amount, and there’s nothing for me. I tried using the MiniTool Partition Wizard as suggested by one user, and it found nothing to recover. It’s as if the drive exists, but it has no memory to speak of. Can someone help on this? I’d love to get access maybe just once so I can take everything off it. It’s my main HD for backups and storage so it’s quite important.

Thank you for reading, I hope you can help.

Ps It will not allow me to choose either option in the dialogue box either


If you proceed and initialize the disk it will delete all data stored on it.

I recommend just for troubleshooting purposes that you try on another computer and also use another USB cable. You may also try using a data recovery software in order to recover your data.

Hi, I also have same problem. My passport 750 gb external disk has same problem, under computer management section, ı just see disk 1 without any data storage capacity, I have tried many recovery program, like recuva, r-studio etc. Only R-studio can see my disk but not able to scan.

hi Martyn_Dickinson, I have same problem as yours. If you have any solution, please let me know. I have been trying to solve this problem since 10th january, :frowning: