Not getting Activation code for adding mobile device in WDTV LIVE HUB

Since I couldn’t reply to a previous topic with the same problem…I’ll just repost, and yes, I have the latest firmware.

"

In Setup > Mobile access > Mobile devices > Add mobile device > Get code,
I am not getting any activation code. Next screen is shown in a split seconds and comes back to Add mobile device menu.

Observed that the screen which flashes, has no activation code. Only two hyphens are displayed with spaces in between.

"

I should note that I haven’t had any problems syncing My Cloud drive with the WD Photos and WD Cloud apps…just the Live Hub…and yes, it is connected via ethernet to my network, as I am able to access both the Live Hub and Cloud from my computer/network.

Hi brentjf, have you tried power cycling the WDTV? If the problem continues you can try pressing the reset button. 

Hello,

I’ve tried power cycling several times and even unplugging the power from the unit once it has been powered down.  It is able to access the internet, as I was able to use Netflix.  After “Get Code” it just reverts back to the “+Add mobile device” page.