Not all subtitles work when selected. Only subtitle 1 will be displayed

I bought the WD TV Live this week and I have this strange subtitle issue.

When playing an ISO file, I can change between subtitles ( ie. subtitle 1 English, subtitle 2 Dutch, subtitle 3 French etc).

The problem is that the WD TV Live only displays the English subtitles. When I select subtitle 2 Dutch, the WD indeed says ‘Dutch’ on the top left of the screen, but the subtitles never appear. Only when I select subtitle 1, those subtitles will appear. There is nothing with the files I guess as the subtitles are there and do work on other media players. It is as if only those subtitles on the first ‘track’ work and those on the other tracks (2,3,4, etc) don’t.

Any suggestion as to what may cause this problem? Hope I gave a clear desciprion of the issue…


Did you check to make sure all subtitle tracks are supported by the WD Live SMS?

Also, make sure the separate track has the same name of the file including the compatible file extension.

Check the link bellow for more information.

 List of compatible media file types for all WD TV and WD Elements Play Products


BD ISO.....

Yes I did check and the subtitle tracks are compatible…

I think it may be a firmware issue. Went back to the store this morning and brought my iso files with me. On the demo model they had on display, everything worked as it was supposed to. They ran version 1.15.10 while my device had upgraded to 2.01.86 during the intial setup. The guy in the store advised me to downgrade the firmware. I followed these instructions but did not succeed in downgrading the firmware. My device kept saying ‘your WDTV is being upgraded. Do not disconnect power’ but the status bar remained on 0%. Anyway, to make a long story short, I went back to the store again and swapped my device for a new one. When setting it up again at home, I did not perform the firmware upgrade. The device I have now, came with 1.16.13 and that works fine too.

What do you think? Could it be the firmware or did I just happen to have a ‘bad’ model since I also was not able to downgrade the firmware? I now just don’t dare to upgrade to the latest version (2.01.86) anymore…

You’re sure the Dutch stream wasn’t a forced sub with only a few items so it appeared empty? I’m on 2.01.86 but I use MKV instead of BD ISOs.

Yeah, I am, it’s forced. MKV’s worked fine it was just the iso’s. Only the first subtitle worked, the other ones didn’t. Usually it is English on the first subtitle track, so then I can only watch that. But I also have a few ISO’s where Dutch is on the first and then I see those and can’t see the English ones if they are on track 2 or above. It’s the strangest thing indeed…

In fact it is. For a test I’ve ripped my Avatar BD to ISO, main movie only and complete movie. I could cycle through all streams of the complete movie but only got the first subtitle stream on with my main movie rip (both played from the main dir, not from inside a folder). Weird.

1 Like

Ah, so you were able to replicate this error. Great, I am not crazy after all :wink:

Thanks for helping!

Then I guess it is indeed a firmware issue as everything works fine on 1.16.13. This version was released in December if I checked correctly, I can’t believe I am the first or only one to notice this?!

Hope it will be fixed in a next release and WD is reading this too…

I’ve tried another rip an apparently it’s not because of main movie vs complete disc but some tracks vs all tracks. Can you rerip your BD with all sub tracks and once again with only some tracks and see if it makes a difference?

I could but the thing is I am now on 1.16.13 again where the issue does not occur. I do not dare to upgrade as I did not succeed in downgrading the firmware last time and I ended up returning my device at the store where I then got another one.

When I was still on 2.01.86 I tried at least 8 different BD ISO’s; some I downloaded a few years ago, others recently and all had the issue. All had multiple subtitle tracks though.

Well, I’ve passed this on to WD, let’s see what they make of it. Still weird, you couldn’t downgrade to 1.16., worked fine for me (back on 2.01.86 now).

Great - well, please let me know once you hear back from them. I also raised it with them over the phone, but haven’t heard back yet. Perhaps you have a better relationship with them.

Thanks for your help.