Not Accessible/Visible in File Explorer

Hello,

I recently experienced this issue, I’ve had this drive for quite some time. At first it was suddenly telling me across all my computers that I did not have access and access was denied.
This escalated into outright not having the drive visible at all.

I then noted in Disk Management that it does show up…Not Initialized…even when clicking to do this I encounter a fatal error and cannot even Initialize it losing all data as stupidly this is what drives do, even though their very existence is to shield and store your valuable data.
Of course, I can go with the typical, I have my entire music collection, valuable images and videos of various degrees as well as a decent amount of notes and more for my book. Losing this data is as expected for anyone who bought these things in the first place, a drastic blow.

if there is at the very least a way to repair this (which I largely doubt) or a method to at least get something to recognize the drive so I can get my data so I can thus put this external rightfully in the trash where it belongs would be pleasant.

Any help is greatly appreciated

You have my sympathies having just gone that (slightly different) route. There was a time when you could just “pop” the drive out, install it internally and retrieve your data, BUT, in WD’s infinite wisdom, they have made this impossible. They do ALL sorts of things to the drive NOW so that option is no longer viable. Your ONLY option is now to pay an arm and a leg for some thieving organization to recover your data.
I would imagine they have an easy method to do this (recover your data) for which you will have to pay dearly. But, reading your tale of woe, I suspect yours will not be an easy recovery, sorry to say.
I would suggest, for further requirements, you bypass Western Digital’s XHDDs. I believe Seagate still supports easy recovery of data from a failing XHDD?
Good luck, you’ll need it :frowning:

I appreciate the reply louwin

That is utterly devastating news to hear as a literally just purchased a housing unit to do that very thing…sheesh.
I’ll look into Seagate going forward. Sending it off to some person to snatch up my data was my last resort. I have a few more things I’m planning to try to see if I can get into it. Unfortunately, I’m going to have to cash out to get that data if it comes to that. I’m an artist, writer and solo game dev and everything from notes, game plans/ideas, codes for two planned games, artwork, 3D models of characters and the first book are on that dang thing. I have minor backups in the cloud/google (so I didn’t lose EVERYTHING) but not only do I not trust those as much to not get snuck into, they often don’t have enough space to hold everything that I do.

In the future I’m figuring I’ll just have 2-3 drives and be updating all 2-3 constantly with all my data and when one burns out I’ll replace it with another so that I consistently have everything backed up on all 2-3 XHDDs. Seems to be the best way to go for me.

I again appreciate the reply!
I wish you well.

eleyon…sorry to see that you are no longer seeing the WD drive in your Explorer.

  • did you try safetly ejecting and trying another USB port or another PC? You probably did…
  • if you can see it, but cannot see folders/files could be a permission, however, sounds like you have been using this drive for some time…unless you recently changed PC’s
  • really looks like a drive issue rather than a software problem with Smartware or Backup. I see that Smartware may not work with Win10.
  • did you try downloading the “WD Drive Utilities” software, maybe there is something there to query the drive, but if your dive is unreachable, it could be broken…not sure which external HD you are using. I’m on a Passport and normally post under the WD Portable Drive forum…came here from curiosity.
  • as far as Segate or WD…the main thing to remember is that multiple hardware with similar backups are always the way to go, especially if it is your Lifeline…hope the Good stuff is still on your PC so that you can do a full backup onto a new drive(s) of all your important data. Good Luck!

Appreciate the reply!

  • Certainly tried safely ejecting and trying another USB port as well as trying on another PC. I was planning to try and see if something on a different operating system, aka Linux or even a later version of windows is able to jog it so I can at least extract everything from it. Will try that later
  • It’s odd, at first I could click on it and would just get access denied, something I could fix, however it quickly escalated into acknowledging the drive is plugged in (even makes the noise when I do) and shows in my devices, etc however it’s utterly absent from File Explorer. Noticed it was coming up as Un-initialized and said screw it but that received a fatal error and didn’t work as well. I can still hear the drive seemingly spinning and being active, so that’s why I figured I’d get a new housing, but as the other poster noted, they nipped that in the bud…
  • I’m thinking it’s a drive issue also…
  • I tried downloading a few WD things but not quite that, I’ll give that a shot and see. But in alot of the other programs I tried, it is as you said, because it’s unreachable they’ll see it but often times give me no options as they just can’t get access. I’m using a WD My Book, had the serial and such around here somewhere. I had a bit of trouble navigating through the forums, so hopefully I posted this in the right place.
  • That’s certainly the plan going forward…I’ll just keep two XHDs and consistently update both, if one sputters out I’ll replace it to keep the “Rule of Two” intact. I have most of the barebones, but because alot of it is development and thus I wanted a drive that could be useable between my PC and laptops. I have most the essentials in my cloud drives, but that couldn’t hold things like the excess 3D models, animations and overall size of the game projects in Unreal Engine 4. so those were on the drive unfortunately…I’ll stand to lose quite a bit of character and concept art as well, a well of sound files from the OST to voicelines and even sound effects. Some is on cloud drives but certainly not all…maybe not even most. This is fairly disheartening as I was JUST in the process of getting another drive to support this one, just didn’t get here in time so luck was awful.

appreciate the well wishes!
I wish you well also, thank you for taking the time to comment!

eleyon…so sad to read you horror story and can feel your pain and frustration. Hope this prepares you and others going forward.

  • not sure if the WD Drive Utilities can help since you cannot even see your device in Explorer. Could be some USB driver issue but it’s something I could not suggest or know what to do.
  • its hard to vent on a forum, but sometime it helps…
  • too bad WD support does not try to chime in and offer real suggestions.

Depending on how much it will cost to recover your data through a “Data Recovery” service, I’m loathed to suggest you buy another one of exactly the same size and model… Crack open the new one and get it’s USB interface and put it on your current drive, also extracted from it’s enclosure. It MIGHT work and maybe cheaper that the cost of data recovery service?
Also, if you bought it a long time ago, the extracted drive MIGHT be installable as an internal drive, and accessible that way? Hopefully, it was before WD started playing their silly games with encrypting and all that sh*t!? Like I said - consider the cost of your various options…
Good luck.

I have the same issue. FYI I contacted the recommended “Data Recovery Partner” in my area. The minimum charge they quoted was $400 and it could be as high as $1000.
That is extremely pricey.
I am going to buy another unit and try swapping the read/write head. If it fails it fails. If it works it will have only cost another $80.
Good Luck

Thanks for the reply Mike!

it’s looking like after exhausting everything I know I’m able to try going to a “Data Recovery Specialist” is my current option. I’m not sure how to swap the read/write heads myself personally so I’d probably be on the fail side. I’m sure I could no doubt look up tutorials. Haven’t personally got a quote on what it would take to get the data off my drive but they did indeed quote me anywhere between $100 - $1,100.

Thanks and I wish you luck also!
If you don’t mind dropping in to let me/others know your results that would be awesome!

eleyon…reading back thru this thread sound mode like a hardware, since I believe you have been previously using this HD. I don’t think you are moving from one PC to another with the same HD?

  • PC to PC move…I see some WD posting about Permissions.
    https://support-en.wd.com/app/answers/detail/a_id/8752
  • if its software, maybe a Virus checker program is got something blocked…try turning it off
  • run a Malware program, again if things just happened after prolong use of the same HD
  • I’ve used BestBuy, Geek Squad on some occasions. Ended up paying for 1yr service.

If all else fails try “shucking” the drive and mounting it internally. I suspect that is what the data recovery people will do anyway…

There might be “disk unknown not initialized” issue occurred, where your hard drive may show unallocated space in Disk Management, and the data on which will be inaccessible or else there is another situation: there is no disk space shown in Disk Management.

There are a few possible reasons behind hard disk not initialized as below:

  1. File system corruption.
  2. Virus infection.
  3. Bad blocks and sectors.
  4. MBR damage.
  5. Connection problem.

You can give a try to below mentioned 2 different methods to resolve the issue:

Method 1. Use Disk Management to fix not initialized error on external hard drive

  1. Connect uninitialized external hard drive to your PC.
  2. Press Win + R keys, type: diskmgmt.msc and hit Enter.
  3. Find the uninitialized, unknown external hard drive with I/O device error > Right-click on it and select Initialize Disk.
  4. Then set the disk to initialize and set disk as MBR or GPT.

After this, you may reboot your PC and keep all changes. Now, your external hard drive will be recognized and read by Windows again.

Method 2. Run CMD to repair I/O device error on not initialized external hard drive

This CMD command would erase all data on the uninitialized hard drive, which you can later restore after repairing the external hard drive not initialized, with the help of any data recovery or partition recovery software:

  1. Press Win+R > Type: diskpart and hit Enter.
  2. Type: list disk and hit Enter.
  3. Type: select disk F and hit Enter; (replace F with the drive letter of an uninitialized external hard drive).
  4. Type: clean and hit Enter.
  5. Type: convert gpt or convert mbr and hit Enter.
  6. Type: create partition primary and hit Enter.
  7. Type: format quick fs=ntfs and hit Enter.
  8. Type: assign and hit Enter.
  9. Type: exit and hit Enter.

In case you wish to recover data from the drive you need help of a reliable data recovery software. Here, I suggest to try Free Stellar Data Recovery Software to run a scan & see the results. The free version of the software also enables you recover 1 GB data free.

See if this helps: G-Drive partition corrupted