Not able to write data to NAS drive

Hi,

I am trying to copy some data to a folder created under Download folder on NAS drive.

However I am unable to copy the data. I get an error message saying permission denied. Please see the screenshot download.png to see the error message.

  download.png

So I tried going to the WDS tool and reconfiguring the access rights. Even after giving full rights to the administrator, I am not able to copy the data.

Please find the screenshot users.png attached for the  same.

  users.png

Also I tried creating a folder by another name under Folder Shares. However I get some error message as shown in the Storage.png screenshot attached.

storage.png

Could you tell me  what is the exact problem and how I can resolve the same.

Regards,

Siddhi

Check the RAID manager to see if one the drive failed

Do you have any issues when trying to copy to the public share?

1 Like

I am having a similar problem after two years of owning my 8 TB WDShareSpace with relatively few problems, especially with write protect errors.  All of a sudden it won’t let me write files to any of the shares, even though I haven’t changed any of my settings - I checked user credentials under folder shares adn it’s still read/write.  I can read, copy, etc., but all of a sudden I just can’t write.  There is plenty of space left on the array, and all of the drives check out to be fine when I check the status on the admin interface.  But I get the error message that the share is write-protected or full.

I don’t know if it’s related but I have also experienced a lot of intermittant problems browsing thru the admin interface - pages time out, Iget kicked out, etc.  FTP is also failing to bring up directories intermittently - after logging in, you can’t see the folders. 

These problems have persisted since updating the firmware recently, much to my dismay.

I am dead in the water  without being able to write - is there a solution or should I send this brick in to get replaced?

Have you already checked the permissions on the drive and verify the RAID is working? 

You certain you did not change anything via SSH? 

Thanks, but I have checked my permissions on all shares, still full access RW.  My SSH has never been enabled and I have not otherwise changed any settings.

Have confirmed that FTP user after logging in also cannot write to Downloads share, which has full access granted to user…

The array indicates that all drives are Good, raid is Good.

So I am still dead in the water.