Not able to view HD contents

Last week I bought a 2TB Ultra My passport. 
Yesterday when I was trying to copy files into it, it showed that the space I am tring to copy to is not available. I disconnected and tried connecting back, but nothing happened since that.

The LED light stays on(not blinking) for the duration of period it is connected to the PC, but nothing happens… Is there anything more I could try out??


If you are able to see the drive but not view its content then it means the partition is corrupted. If you format the drive you will be able to use it again but formatting will delete all data stored on it.

 It may be possible to still extract the data utilizing data recovery software. There are several kinds of Data Recovery software available. If you do a  web search for  Data Recovery  it will yield plenty of data recovery software options.

My problem is that the storage device doesnt show up anywhere in the system, Disk Management or even in Device Manager. I tried it on a Mac as well, but the only thing that happens is the led lights up and can hear a rotation motion inside. Nothing else. Any other way I can troubleshoot this? Or should I replace it?