Not able to see more than 380GB with 2.5 TB

I’ve just bought a sata 2.5 TB hdd modek WD25EZRS, I tried to mount it both in windows Vista and MAC OS X, both OSs can see no more than 280GB before initialization. I already downloaded all WD software. I already followed all WD instructions. I have no driver troubles. Could you help me to find a way out ?

You say that you have no driver troubles, but ISTM that’s exactly what you may have. In any case, it does appear that something is imposing a 2TiB limitation.

2.5TB - 2TiB = (2.5 x 10^12 - 2 x 1024^4) / 1024^3 = 280.3 GiB

http://www.google.com/search?q=(2.5+x+10%5E12±+2+x+1024%5E4)+/+1024%5E3

Can you tell us your Windows configuration, ie motherboard, chipset, SATA controller, Windows version, etc?

Could you tell us the properties for the drive in Device Manager?

How is the SATA port configured in BIOS? Native mode? Legacy mode? AHCI? RAID?

Thanks fzabkar for your reply, I suppose there are no driver troubles because in both OSs (Windows and Mac) I can see the HD with no particular warningor error messages, but, as I wrote, I just suppose it. I tried to use WD HD with two different hardwares in order to understand whether the problem is hardware or software related. First attempt was with Notebook Acer Travelmate 6292 running with Windows Vista, second attempt was with Desktop Mac Mini (early 2009) running Mac OS X 10.6.2 During both attempts I connected WD HD to Sata USB port (external HDD USB Drive) In order to understand what was wrong I did a third attempt with the notebook running a special software called “Paragon HD Manager”, but the problem was not solved WD HD is connected with no jumper. Thanks again for your attention Regards

How old is your motherboard?  Sometimes there can be an issue with an older BIOS.  It might be worthwhile seeing if there is a BIOS update for your motherboard.  Normally the MB manual will give instructions how to do this.   I had a similar problem trying to put a larger drive into my laptop. In that case it refused to see more than 120gb. In this case I used  some  software than loads at boot time  and the  drive information forces the BIOS to recognise the correct size of disk.

Thanks robindg for your reply, as you see in my previous message I used two different combination of hardware/OS, with the external USB HD Drive I can see, without any hassle, HD up to 1.7 TB. Therefore probably there are not problems related to the BIOS, but I am not 100% sure. I never tried HD larger than 1.7 TB. Anyway your suggestion is interesting, could you give more details about how to force BIOS ? Thanks againfor your attention Regards

For Windows, you need to be using the x64 version  to see and use any disk larger than 2 TB

as that is the MBR limitation

Windows 2000-Pro through to all Win7 32bit versions can’t use any single disk that larger than 2TB

including  the 32-bit server products 2000, 2003, 2008R1

to use any disk larger than 2TB you must use a 64-bit OS and a GPT partition

here’s the WD Help article about it:

http://wdc.custhelp.com/app/answers/detail/search/1/a_id/2754/c/130/p/227,294

Oreste, it wasn’t clear from your first post that you were connecting your drive via a USB port. In this case it appears that your USB enclosure is imposing the 2TiB limit. I believe this limit arises due to the fact the USB-SATA bridge chip inside the enclosure is limited to 32-bit LBAs.

According to the document below, the WD25EZRSDTL has 4,883,781,168 LBAs.

In hexadecimal, this equates to 0x123189630.

http://www.google.com/search?q=4883781168+in+hex

If you consider only the lower 32 bits, then the bridge can only address 0x23189630 sectors.

The visible capacity will therefore be …

0x23189630 sectors x 512 bytes per sector = 301.5 GB = 280.8 GiB

In short, you need to purchase a compatible enclosure, or you could cut the capacity of your drive to 2TiB using a tool such as HDAT2.

WD Caviar Green Desktop Hard Drives (spec sheet):
http://www.wdc.com/wdproducts/library/SpecSheet/ENG/2879-701229.pdf

Hi Oreste

The fact that you can see an extrenal 1.7 tb drive plugged in to the USB port would suggest that the problem could likely be with the BIOS. The reason is that  drives connected via USB are not dependant on the BIOS to recognise them but are recognised through the Windows  (or Mac) software . I had the same situation with my old laptop. Extrernal drive - no problem but internal nothing greater than 120gb. So teh fact it will recognised large drives via USN but not ones physically attached to the motherboard strongly suggests it is a BIOS problem. 

First thign would be to try to find ut the make & model number

 Then at boot up press teh del key and this shoudl bring up the BIOS setup. the screen will vary according the make of chip used but somewhere there should be am indication of the  bios version and date

Note that down and then go the website of the motherboard manufacturer  and find the motherboard type. Usually there is an option for downloads. You can then look at what is the latest  version. There will usually be lists of what the different version fixed. Download the latest version and save to disk and then copy to a memory stick.

the motherboard manufacurer should have instructions on their web site how to do the BIOS upgrade. Download and prtint this out.  the procedure varies with make - and age. Generally the newer motherboards it is a lot easier.

If you are not too familiar with the procedure see if a friend can help. the main thing is to follow the instructions carefully and make sure  if possible your PC is connected via a reliable power supply (preferably a UPS) If the process is interupted i.e. with a power cut (as we suffer from where we live  hence everything plugged in to a UPS) it can damage the BIOS chip. However it usually only takes a couple of minutes. 

the other way round is to get a piece of software installed on the hard drive which enables it to get round the BIOS limitation. I’ll check later on teh WD site and see what it is called.