Not able to see media files via DLNA

Hello,

I have a MyBook Live 1TB & have copied all my downloaded movies & songs to the default shared folders on this drive.

On the DLNA menu on my Sharp TV (LC70LE732U), I can see the MyBook Live server & am also able to browse through the folders but not able to see any files. After going to the last folder I get No Data Available.

Recently updated MyBook Live to the latest firmware.

The TV is DLNA certified also.

Is there anything wrong I am doing. Any help would be highly appreciated.

Thank you.

2 things:

  1. Did you enable media serving on the folders of the MBL and gave streaming permissions in Twonky to allow the TV to play the files?

  2. Can your TV natively play the files you are trying to play?

Hello,

Thank you for the reply Pizza Matrix.

To answer your 2 questions:

  1. I think I have given rights to the TV to access media from the drive. On the TV I can see the server listed & can browse into the folders, but no files in the folders. Maybe I have done something wrong? Would you please be able to list down the steps as to how I go about giving proper access? That would be very helpful.

  2. Yes, the TV is able to play the files. Before I bought this drive I was using my Win7 laptop to stream media via Windows Media Player & the TV could play those files.

Thanks

This Sharp TV supports the following formats. Are you sure you have media in these formats?

Photo file format JPEG
Music file format LPCM, MP3
Video file format MPEG2-PS, MPEG2-TS,
WMV, ASF, MP4, MOV, AVI

Yes, i can confirm that the media is in these formats.

thank you

WDBhat wrote:

  1. I think I have given rights to the TV to access media from the drive. On the TV I can see the server listed & can browse into the folders, but no files in the folders. Maybe I have done something wrong? Would you please be able to list down the steps as to how I go about giving proper access? That would be very helpful.

Thanks

Part one is done, the TV as rights to access the media, but is the MBL itself giving access to the media? This is what I meant.

Log to the configuration page of the MBL> Go to Shares> On the left panel you should see the media serving option of the selected share so you can select what kind of media is the MBL allowing to be played and seen.

I have checked the settings as described by you & it was already set to the default ‘All’. I have attached a screen shot of the same.

Still doesnt work. :frowning:

Picture1.jpg

If you browse to the Twonky Control Panel

http://(ip address of your MBL)/:9000

Do you see the media under the Media Browser there?

If so, it’s possibly an incompatibility between your TV and the MBL.

If NOT, then we still need to find out why the MBL doesn’t like your files.

Yes I do see them. If there is a compatibility issue with my TV, is there any work around that?

Thank you.

Picture1.jpg

It seems there is no work-around for my problem. I have no option other than returing this product. I wrongly assumed that all DLNA compatible products can communicate with each other.

The one solution I have found is upgrading MBL to the latest Twonky Server version, but WD won’t issue the new firmware because "they don’t care & don’t want to’. I would have still kept the drive had WD said they would update to the new version sometime in the future, but they have been bluntly refusing to do so. This has been discussed extensivly on these forums. Although I can’t understand why, but it’s better for me to stay away from products which won’t be updated to keep current.

Thank you everyone who tried to help.

I had the same problem, maybe I can help you.

I also saw all files like you over the browser on the twonky-site, but didn’t see any files on my tv.

I solved the problem on the setup twonky site under “Shares”. I had to search the directory (in my case “public”) and then choosed “Add new directory”. Because there you decide, which directory you want to share.

Unbenannt.jpg

After that I could see and play all my files over my tv.

Greetings from Germany

Markus

1 Like

Hi Markhus,

Thanks for the pointer. But, I am not clear where I should add the directory. In my TV? Would you please be able to send me a screen shot or something?

Regards

It worked!  :smileyvery-happy: Thanks Markus.

For some reason my Windows PCs were able to see my 666 videos via network share or media server but my WDTV Live Hubs and Android devices would only see them via network share.  After 2 trolling around the forums I found this post, tries it and now it works.  I would’ve expected that the Public folder was shared by default but I guess I was expecting too much.

Ray