No write access to external hard drive with Mac Finder

I have problem with Mac OS X 10.6.8 and WDTVLive Streaming Media Player. I have connected my external USB hard drive (USB drive model is Buffalo Ministation 500 GB and it is formatted to HFS+ filesystem) to my WDTVLive Streaming Media Player. I can see hard drive in Finder (Under Shared title in left pane), but I can’t create new folders or copy new files to it. When I try copy new files, system gives me dialog which tells me that there is only read access. I have logged in my mac using administrator rights.

I tried also to use my USB memorystick which uses FAT32 filesystem. There is same problem. No write access. When I connect hard drive (or memorystick) to my Mac using there are no problem with write access.

Do you have any solution how to put write access on? What should I do? It would be nice option to use Finder when transferring files to external hard drive instead of connecting it with Mac.

on the SMP when enabling a share do you turn on the share password as well?

if not try that, it should force the mac to use a log in to access the share.

I have tried to to turn off/on sharer server, but it won’t help. When turning on sharer server, SMP asks me am I willing to set security on. I have tried with security (by giving username and password) and without. The result is still same: no write access. In Finder I have tried logged in to my WDTVLive using Visitor account (no password and username) and account which I have created to WDTVLive. No access. Network Shares from Mac to SMP works properly (Samba is ON), so I think that network settings are OK. Do I have put some other network services on to get access to SMP? Does SMP’s sharer server use some other protocol for sharing?

It’s weird problem… I don’t have any idea how to solve it. Thanks for help! 

that is very weird. I know for a fact it works as I have a family member with a MBP and he rarely removes the drive from the SMP.

he usually just transfers files to it through the share and has never had any problems.
he’s not using a share login/pass either. I can’t explain why its not working for you.

my only thing would be to make sure both are updated and if that doesnt work try and exchange the SMP at the store for another.

I have updated both devices. I think I have latest firmware in my SMP (1.06.04). I have also installed every updates which Apple Software updater have offered to me. So my Mac and SPM are up to date.

New thing point is following. I noticed I can delete files and folders in SMP’s USB-drive. In Mac’s Finder I have fixed rights for USB-drive. How can I delete files and folders if I have read-only rights? It is confusing…

Maybe next step would be to use other computer. I’m going to try Windows based computer or some other Mac. If it works properly when using Windows problem is in my Mac. 

Any other ideas how to solve this? Every tip is very appreciated. And many thanks to Ripcord83 for answers!

I had the same problem:

I connected the external hard disk (hfs+ not journaled) to my mac, then updated all the disk permissions to read/write to all files on the diskand then it worked when connected to the wdtv via wifi

to do so:

connect the disk to the mac

  • right clic (control click) on the disk icon on the desktop
  • click Get Info
  • unlock the bottom right lock on the info window by typing yr os x credentials (if applicable)
  • give all the users (you - staff - everyone) read/write permissions
  • then click on the gear icon and select all included elements

that should do it when you reconnect the hd to the wdtv.

let me know if that works for you


1 Like

Many thanks for your help!

I did as your said and now it works. Now I can copy new files and folders to USB-drive which is connected to WDTVLive Streaming Media Player. 

I’m having a similar problem in 10.7.2 except I cannot even get that far - 

" I can see hard drive in Finder (Under Shared title in left pane)"


I can see the WDTV , but cannot “mount” it due to it requiring a password and user name.

What appears is - Connection Failed.

 If I try to “Connect As” Registered User  - I get prompted (“Enter Your Name and Password for the Server WDTVLive”) 

If I try to connect as “Guest” it fails.

NO CLUE what the password is, or how to find it, change it, create it - or DISABLE IT!

I assume it’s maybe on the WDTV somewhere but not in the network settings.