No Writable WD Smartware partition found


I have problem with my MyBook Live in WD Smartware.

Problem is Smartware says of MyBook that “No Writable WD Smartware partition found”

I found out that it is behaving pretty strangely…

It does NOT work when there is MyBook account with same name as windows account AND they have different passwords.

So when there is not account with same name, it works.

When there is such account but there is no password on it or password is the same like windows account one, it works

It is not a big deal, but is not there a way to make it working with same account name and different password, too?

EDIT: So it does not work anyway, even with the same account and password. When I try to unlock the device, it says

Authentication Failed  -  Access is denied. (Exception from HRESULT: 0X80070005 (E_ACCESSDENIED))


computers OS: Windows 7 ultimate x64 and Windows 7 home premium x64

MyBook Live firmware: MyBookLive 02.32.05-046 : Core F/W

WD Smartware: 1.6.4

1 Like

Hi, since you have the latest smartware version, try uninstalling that one and install the version that came with the my book.

    I am having the same issue.  I had restored the factory defaults on my WD MyBook Live  and the smartware partiton was available.  I had even performed a backup on my system drive.  I also added a user name that was the same as an existing Windows 7 user name.  But when I went back to view the retrieve options, the Smartware partition was not found. 

     I will attempt to remove the user from the WD MyBook Live configuration to see if the result is different.

Computer OS: Windows 7 ultimate x64

MyBook Live firmware: 02.32.05-046

WD Smartware: 1.6.4

Removing the user, with the same name as a windows 7 account, from WD MyBook  Live user list did fix the problem.  I am now able to see the SmartWare partition and all the items backed up.  And I did have different passwords for each.

It seems odd that the two accounts or user-IDs should affect each that way.

Thanks for the post.

Computer OS: Windows 7 ultimate x64

MyBook Live firmware: 02.32.05-046

WD Smartware: 1.6.4

I tried hard reset MBL and still have error. Don’t update SmartWare, because I have this error after update. I instaled older version from cd and works fine. New version have errors.

I had this lots of times last night.

After working perfectly for 3 days I suddenly got this error. I tried different browsers and different addresses but nothing worked. In the end I rebooted the machine (I had to pull the power lead out and wait 3 minutes then reconnect the power) and after than my dashboard was visible again. I also then speeded up the dashboard by disabling twonky and itunes sharing, this has made it twice as fast to load and do stuff. No problems since, fingers crossed. Not too sure about updating either based on what I’ve read in this forum =)