"No Writable WD SmartWare Partition Found" - ONE More Possible Solution!


#1

(SOLVED)

hey guys, I was having the same trouble as most of you when I plugged off one of my WD (MyPassport) external HDD abruptly (without the use of the safe removal) and then I plugged-in another one (similar WD one). I remember when I was trying to safely remove my 2nd HDD, it warned me as to some programs on windows were still using it but somehow, the H: drive icon  when clicked showed the files from my 1st HDD.

Anyhow, impatient that I am and stupid enough to be that - I again plugged off my 2nd HDD despite the warning msg mentioned above. Thats when the problem took a wild turn…

“Do not format it until you have tried everything else” ------- obvious thought but some people just do that…

I had tried almost everything mentioned in the topic with the same subject on this website:

. Assigning different drive name to my HDD under disk management within computer management (several times)

. refreshing and rescanning disk under the same disk management

. scan and fix

. disabling my disk drive under dive manager

. restarting the computer

. CHKDSK :H (or X) (or V) /r with cmd

. CHKDSK :H (or X) (or V) /r with cmd  - cmd started with “run as Administrator”  - said, H: drive is invalid or not found

…etc etc

Nothing of the above worked either individually nor did it in any combinations…

Anyways, I got this working after shutting down (NOT restarting) and waiting for more than 30 seconds and then starting it while the HDD was still plugged-in. While it started, it automatically asked for me to check my X: drive … which i had re-assigned to my external HDD … I didn’t do anything - letting it do the scan … and voi-bloddy-la… it showed my disk had data and it did something with it like “inserting information to sector #####” … something like this…

and finally, when the system was up…I could see my drive with all data intact…thank GOD…

P.S: I have created this new topic for the same discussion as I was unable to reply in the other one… thanks guys in the other forums for the knowledge and help you are providing… !!


#2

Glad to here it worked out for you.