No writable partition found

I’ve had a 1 TB My book WDBAAF0010hbk-00 for about 8 years now, and the USB connector recently broke off. So i took apart the My Book and took out the harddrive. I tried connecting it via Sata to USB to my Windows 7 laptop, but to no avail. So I went ahead and purchased a new 3 TB My Book today (WDBACW0030HBK-NESN) I took it apart, took out the harddrive, and connected my old harddrive. WD Smartware, Firmware is all up to date, and it reads the old harddrive, I type in my password, and then i see “No writable partition found.” 

I have so much data on this harddrive, photos, music, movies, pictures, EVERYTHING you can think of and i CANNOT lose the data on this thing. So i’m not quite sure what to do. I’ve tried partition recovery software, did not work. 

When I initially bought this drive and set it up, it was on an XP machine, not sure if that matters because I’ve installed this drive on a couple different computers, windows 7, vista, etc. It’s always worked. 


I have tried the following:

Connecting the External TB Sata Harddrive to the inside of a Windows 7 desktop. The computer saw the drive, but it was “unallocated” again. There was no recovering any of the data. 

So now im going to try this. 

Connecting the External TB Sata Harddrive, to a desktop that is using Windows XP.

When i first bought this drive and set it up, it was on a Windows XP machine, so maybe this harddrive will only work inside of an XP machine? I dont really know, i’m reaching and desperately trying anything. Fingers crossed.

I don’t know about the older drives but the ones that now come with Smartware are hardware encrypted so connecting as an internal won’t work. If you have the original board see if you can get a USB port soldered on it. You might try accessing the drive with a Linux live CD.


1 Like

Yes it definitely has Smartware on it.  I tried soldering the USB connector back on the chip, but it didnt work. 

I also tried putting the old harddrive into a new mybook, almost the same as my old one, and it just gives me “no writable partition found” 

The only other thing i can think of is buying the exact same mybook that i had and putting the harddrive in there. 

Tried running EaseUS Partition recovery, nothing. The drive is now inside of a dell desktop, and it shows up in Disk Management, but all as unallocated. 

I’m out of options. I’m not sure what else to do to get my information off this disk.

I’m still having problems, but these two links have given me a lot of help