" No WD My Cloud Found" message when trying to install my new device. Really REALLY desperate


I bought this 3TB unit, despite all the negative feed back i read about My Cloud. I said :  lets give it a try, how bad can it be. 

Well i really dont know because I CANNOT EVEN SET IT UP AND MAKE IT WORK !!.

Try everything, and YES ! the blue light is steady and the network connection is Fine. 

I even took the unit to work and try to connect it there, but nope, no luck. 

My brothers house . . . . mmmmm same result.

Reset everything . .  Disconnect . .  . Call the Internet provider  . . . .  mmmm   N O T HI N G !!!  this thing wont work. 

Hope someone can help me out, because i really really dont wanna waste my money and time. 

I guess next time i should listen to feedback. 

It would help if you could explain what your setup is, what you have tried and what exactly “doesn’t work”.

If you connect the MyCloud to your router, and your PC to your router, log on to your router’s admin page and find out what IP address your MyCloud has been assigned. Then open your web browser and enter /ui in the address bar; replace with the address you find from the router admin page. That should give you access to the Dashboard, from where you can set up the MyCloud. If you can’t find the IP address, or you can’t access the Dashboard, then something is probably wrong with the cables or Ethernet interface.

Have you read the FAQ: