No way to disable unwanted services preventing sleep mode

I only use my WDL 3Tb as a NAS for backup purpose.

I bought it just in time to backup my laptop and external hard disk before taking them for holidays and when i came back I noticed my MBL was running (and overheating) at night and was never entering sleep mode.

I dont want anything browsing the hard disk (eg: file_tally in, mediacrawer, miocrawler, etc), analysing content or converting files. I just want a NAS storage - I don’t  want and need no media server or anything else overheating my NAS for nothing and preventing it to sleep.

Unfortunately there is no way to disable such unwanted behaviour from the web interface:

I disabled remote access and twonky from the web interface as well as media serving for all shares before rebooting  but it was not enough.

To achieve my goal I  had to disable /etc/init.d/orion and modify /usr/local/sbin/ (commenting line calling file_tally  and the “check for file_tally sync” section)

I wish to be able to disable all but strictly necessary services (network filesystems daemons and web server) from the web interface in the next firmware version (and I think i’m not the only one).

A checkbox for disabling all goodies and use the MBL as a simple NAS storage would be welcome.

(In this mode, used space for shares and usage statistics on the main page of the web interface (music video photo others) should be computed on demand only)

Thanks in advance.



This a users forum. I have the same advise I gave you before, you may submit this as Idea.  WD staff monitors the Ideas section to see the most voted.