No way to access the My Book Live Duo dashboard and mapping not working anymore on one of my PCs

Hello, I am quite disappointed because I have realized I am unable to access the My Book Live Duo dashboard from both the notebooks connected to my home network. 

The My Book Live Duo IP address on my network is and when I type in Chrome I only get a completely blank page with in the address bar. The source code of the page is completely blank as well. On Internet Explorer I only get an error saying the page is not reachable.

I don’t know if it matters, but my notebooks are running Windows 8.1 and Windows Vista. The one with Windows 8.1 is connected to my router via wi-fi, the one with Vista via cable. 

Among the several attempts I have already made to gain access to the dashboard again, I already tried resetting the My Book Live Duo. I have also tried to set it up again using both the latest setup software downloaded from the WD website and the one that came on disk with my My Book Live Duo. During the setup procedure with the latest software, I get some error messages saying that something is preventing the proper configuration of My Book Live Duo.

Until a couple of days ago, the mapping of My Book Live Duo worked fine on both my notebooks. Then it stopped on the one running Vista and there is no way to set it up again. WD Link can see the My Book Live Duo on the network, but doesn’t allow me to create the mapping of the drive. The mapping, instead, is still working on the Win 8.1 notebook and I can normally access my files on the My Book Live Duo from my WD Tv Live box too.

I have already looked for a solution in the My Book Live Duo manual as well as this forum, but so far I have only found other people having similar problems but no solution. WD official support doesn’t seem so easy to get in touch with, but I hope someone here can point me in the right direction to solve these issues. Thanks in advance for your help.

P.S. I have recently installed on both my notebooks System Mechanic Professional and Zone Alarm firewall. I have already tried to disable them while trying to set up My Book Live Duo and access the dashboard. Unfortunately I don’t remember when was the last time I was able to access the My Book Live Duo dashboard. However it was a long time ago, with another computer I do not own any more.

Hi simorame, have you tried connecting the My Book Live Duo directly to one of your computers? You can try to access the dashboard like this. 

1 Like

Thanks for your reply jubei04.

The good news so far is that I managed mapping the My Book Live Duo again on the notebook that wasn’t allowing me to do so anymore. Eventually I did realize the culprit was the Zone Alarm Firewall I had just installed. Well, in fact I am the culprit because at first I did not notice that the Zone Alarm settings were different on the other notebook, where mapping worked fine, and were preventing me to access the MBLD. I could just see it in my network.

For the rest, unfortunately, so far not so good: I am still unable to access the dashboard of the MBLD. Following your reply and an email from WD support, suggesting something similar, I did try connecting directly the MBLD to one of my computers and running the setup software.

However, so far the outcome is always the same: the software identifies the device but after the preliminary check I get an error message (see the screenshot in Italian, that basically says that I probably won’t be able to change the MBLD settings. Indeed, I’m not). And when I try accessing the dashboard via browser at http://ipaddressofmbld/ or http://mybookliveduo/ I keep getting a black page (and /UI added at the end of the URLs in the address bar).

With a trial and error approach, I did try out other attempts too, at least to rule out any issue I could think of. In particular I did another MBLD reset, changed the router port it was attached to (from a switch to the router itself, which is a D-Link DSL-2740R), changed from static IP to DHCP, tried to run the setup software with another notebook I had not used yet for this. Perhaps I am forgetting some other attempt I have made, but basically for me it’s like looking for a needle in a haystack.

I am now thinking about updating my router firmware, but the latest version available dates back four years anyway and I doubt that’s the real issue. I also tried to find out whether I could find something about the best router settings for MBLD, but only found out something about port forwarding and there is no indication that this could solve my dashboard problem. 

Sorry for the long reply but I am trying to provide as much information as I can in order to help the smarter people here identify the problem. In the meantime, thanks again for your help.

when you power on the unit does it start with the blue light then to the constant yellow and then green? Or does it stay yellow?

iamk2 wrote:

when you power on the unit does it start with the blue light then to the constant yellow and then green? Or does it stay yellow?

I remember seeing the yellow light only when resetting the MBLD. Usually I see the blue light and then the green one, blinking at first and then fixed.

Did you try to access the MBLD directly from Network on your Windows PC?

If you can’t get the dashboard to work, then I suggest you do a debrick. You will not lose your data. There are many debrick guides on this forum. Once you have the equiptment and the Linux OS running on a PC, the debrick takes about 5 minutes.

Hi and sorry for the late reply. After a few tests, eventually WD replaced my MBLD. My problems apparently were caused by a firmware issue that was not possible to fix. It took me a while to save all the data (approximately 4TB) on another drive, but the new MBLD works fine. I have to praise WD support, the Italian branch in particular, because they assisted me very well as all tech companies should, but often don’t.