“No USB device connected” in WD Discovery


#1

I have a new external WD “My Passport” drive as well as an old version. Yesterday, when I installed the WD Discovery software, it recognised both drives. Now today (possibly after an update?) neither drive is recognised and I get the message “no USB drive connected - if you have a USB device, simply pug it into your computer!” and of course, they are - just not recognised! Any solutions to this please? I used the app to turn off the devices’’ blinkers, and now of course, I won’t be able to turn them back on if desired, not manage the drives via the app. I have found one similar question here, but no solutions are offered. I don’t believe I can be the only one! I am running on Windows 10 BTW.


#2

You should follow the steps provided in below article in this concern;


#3

I recently bought a 4TB Passport. I loaded the the software and got the latest updates. I did a large backup of my files using the Backup app. No Problem. When I tried to restore the files however, no success. Although the app could see the drive and the files I had backed up, when I clicked ‘Restore’ I eventually got the error message ‘….please make sure your drive is connected and accessible’ which it quite clearly is. I have tried different USB ports and even a different pc, but always get the same outcome. Can anyone help, please?