No subtitle streaming via media server

Is there a way to get subtitle streaming via media server?  I have both WD TV Live SMP & WD TV Live, both box don’t display subtitle (SRT) if streaming via media server.  Both work fine if streaming via media share, however WD TV Live will display all media files includeing jpgs (movie sheets, thumbnails etc…) and Its comfusing trying to sort through non-video files…  Any suggestions on a good set up if using both WD TV Live SMP & WD TV Live streaming via same NAS??  I currently have all movies in corresponding genre folders with all the movie sheet & thumbs.  I was thinking to put individual movies into its own folder but then WD TV Live SMP won’t display moviesheets on folder level.  My only option would be streaming via media server on WD TV Live, but then it won’t display subtitle… anyone have a better work around on this situation??  

Normally media streaming servers don’t support external subtitles

they do work when the subtitle are embedded 

I managed to get Subs to work using .srt with the PlayOn Media Server.

I tried MS’s Media server with Media Browser, Mezzmo, XBMC & Plex. None of them worked streaming Subs to WD Live TV.

Having the .srt file in the same folder as the movie worked.

The Subtitle Button does not apply here. That works for media directly on the WD, e.g., USB.

I had WD Live play idx/sub Subs when using a flash drive on USB. If you have a number of Subtitle (ST) files in the Folder, the Subtitle Button will show each one as you toggle the ST button. Again, this is local to WD.

In PlayOn, under the My Media tab, ensure you check off Enable My Media. Press Options Button, and under Subtitles, check Include.


Added 6/13/12

Used Network Shares. All ST’s work as they do on a local USB.

Note: To get a language to show in the ST description when you press the ST Button on the WD Remote, there is a convention that’s described somewhere - can’t recall where I saw it.

E.G., for English ST’s






If it’s not included, then you’ll see the word unknown displayed when you press the ST Button.

This applies to Network Shares and Local - not to Streaming.

There’s a list of language codes, search around; I don’t recall where it is.

Such a pity WDTV Live SMP can’t manage SRT via Media Server (DLNA)…

I have an LG DP1W and with both Mezzmo v2.4.x and J.River Media Center  v17.x it’s possible.

For example J.River has options for DLNA subtitles, but for some reason WDTVLive SMP ignores them.


That wouldn’t be such an issue (everything works fine by USB or SAMBA) but using a REAL media server can make up for the many issues and lack of customization in the Media Library…