No Storage Present


#1

I pulled an old 30GB HD from a toshiba laptop and put it in an Ultra external case but after reformatting it several times, both on Mac (non journaled) and windows (NTFS and Fat32) the WDTV cannot detect it. I have tried both USB ports on the WDTV.

The drive works because I can read and write to it on Mac and Windows and the WDTV has the latest firmware and works with any flash drive I use with it and works with other 320GB external drive I have that is formatted for Mac (Journaled).

Has anyone had this kind of problem before.


#2

Along with the WDTV, I also bought a Seagate FreeAgent 1.5TB external drive last week.  The WDTV would not see the drive over USB even though my PCs and laptops could.   I reformatted NTFS as well as ensured that it was “ejected” from Windows before moving it.  I always got  “No Storage Present”.

I happened to have a $15 USB-SATA dock and a Seagate internal 3.5" 1.5TB SATA drive sitting around the house.   I connected those up to the WDTV, and they worked just fine.

So I returned the FreeAgent drive to Costco and saved myself $129.