No Storage Present


#1

I got a WD HD TV Media Player for Christmas.  It works with my Seagate FreeAgent Drives but does not work with Hitachi and WD drives in ACOMDATA USB Enclosures.  Has anyone experienced this problem?


#2

From the WD Tech Support Knowledge Base

Problem:
My NTFS formatted drive is not detected when I connect it to the WD TV.

Cause:
When a device is improperly removed from a computer, the OS sets a “marking bit” on the drive showing that it was not properly removed. If this drive is connected the WD TV it will not read the drive because it reads that marking bit that shows it was improperly removed.

Solution:
Connect the drive to a Windows 2000/XP/Vista computer, and safely remove the drive. This will change the marking bit to show that it was properly removed. The WD TV should then read the drive.

Note: If the above solution doesn’t work, make sure the cables and drive are good, or Contact Us for further help. Also, if the drive is larger, it may take a while for the WD TV to fully index the drive.

It is possible but I will have to wait until I am home to test to see if this is the problem.


#3

wasn’t expecting to see someone with the EXACT situation i’m having.  i actually JUST bought an ACOMDATA external enclosure today along with a 1.5TB WD hard drive.  and like you, i’m getting a “No Storage Present” message whenever i plug it into the WDTV.

the ONLY workaround i’ve noticed is by going into settings and doing a System Reset to revert all settings to their defaults.  doing that makes the WDTV recognize the drive upon completion of the reset process.  why this works is beyond me, but i don’t think i should have to do it ALL the time just to make the drive noticed.

and this workaround needs to be done EVERY TIME the unit is turned on.  and the whole situation with having to Safely Remove Hardware is a non-issue; i’m almost certain most people have enough common sense to remove their hardware the proper way before disconnecting it from a computer.

i sincerely hope WD is working on a fix for this.  idk, just for the heck of it i’ll try again later.  maybe it’s some sort of weird fluke.


#4

I a getting no stoage present and have tried resetting the settings on the WD TV. I have a mybook (white lite - world) and it has movies and music on there. I’ve already checked to make sure… sure enough, I have tried TWO usb cords (both new) and it still says no storage present. Additionally, only the power light is showing on the WD TV and the other two are not… PLEASE HELP!!!